Fixed by changing in /yo/poky/meta-gumstix-extras/recipes-extended/gawk/gawk_4.0.1.bbappend 

-PRINC := "${@int(PRINC) + 2}"
+PRINC := "${@int(PRINC) + 1}"


PS: CentOS release 6.3 (Final)

--
Nikolay


On Tue, Jul 16, 2013 at 9:32 AM, Nikolay Rogoshchenkov <nickolayr@gmail.com> wrote:
I'm currently trying to building the Gumstix-console-image following the instructions here: https://github.com/gumstix/Gumstix-YoctoProject-Repo/blob/master/README.md 
Every thing works good until the end when bitbake tries to build the rootfs image. I get the following error:

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
[...]
Processing man-pages...
Processing udisks...
Processing u-boot-mkimage...
Processing base-passwd...
Processing zip...
Processing findutils...
error: Failed dependencies:
        /bin/gawk is needed by vim-7.2.446-r11.3.armv7a_vfp_neon
ERROR: Function failed: do_rootfs (see /backup/yo/build/tmp/work/overo-poky-linux-gnueabi/gumstix-console-image-1.0-r0/temp/log.do_rootfs.19883 for further information)
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 Is anyone else having this issue or have any ideas on how to fix it? Thanks.
--
Nikolay