I was having a similar problem, I believe.  It looked to me like the dhclient was giving up before the wifi was active, even with a 60 second timeout specified.  I solved it at the time by hacking in an explicit call to dhclient in the wlan0 config, figuring I would clean it up later:

auto wlan0
iface wlan0 inet dhcp 
        pre-up wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -B && dhclient
        down killall wpa_supplicant

I say "I believe" and "at the time" because I am now using a newer image/kernel that does not exhibit the same problem.  In both instances I was using a build based on the .33 kernel.  I am currently using 2.6.33-r75 and a build based on the omap3-console-image with an Air module.  I didn't bother to see if anything changed related to this -- just happy to be able to cross it off the list.

Doug

On Thu, May 20, 2010 at 3:56 PM, vwyodapink <vwyodapink@gmail.com> wrote:

Have you had any luck solving your wifi issues by chance? I am able to
connect manually but mine does not stay connected long or if it sits idle to
long disconnects on its own. As well as a few other connectivity issues.

Just hoping you got yours working right and you might be able to share what
you did as I am feeling stumped as to where to go from here with my wifi for
the overo fire.

Thanks

-J

Anil Jacob wrote:
>
> I tried the palmtop version of the gumstix overo build and it resolved the
> LCD resolution issues.
>
> But still my gumstix is having the wifi related issue. It fails to attain
> wifi connectivity at the boot time. But I can run the 'wpa_supplicant',
> with a  'wpa_supplicant.conf' (those interested can check out the
> configuration given below) file and 'dhclient' for having a wifi
> connection once I booted into the console. I updated the
> /etc/network/interfaces still I could not manage to make the wifi working
> by restarting the network using /etc/init.d/networking restart command.
>
> Does anybody think its a particular issue or somebody else facing the same
> issue ?
>
> #contents of my wpa_supplicant.conf
> # allow frontend (e.g., wpa_cli) to be used by all users in 'root' group
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=root
> #
> # home network; allow all valid ciphers
> network={
>       ssid="your_wlan_ap_name"
>       scan_ssid=1
>       key_mgmt=WPA-PSK
>       psk="your_wpa_password"
> }
>
> This is the print coming during the kernel booting.
>
> Configuring network interfaces... ADDRCONF(NETDEV_UP): wlan0: link is not
> ready
> ADDRCONF(NETDEV_UP): wlan0: link is not ready
> ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
> udhcpc (v1.13.2) started
> run-parts: /etc/udhcpc.d/00avahi-autoipd exited with code 1
> Sending discover...
> Sending discover...
> Sending discover...
> ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
> No lease, failing
> done.
>
>
>
> Anil Jacob wrote:
>>
>> Thanks Edgardo,
>>
>> But few more doubts in my mind, I think both the desktop and palmtop
>> versions are using the same linux base kernel. And both of them are using
>> the same DSS and OMAPFB drivers to run upon the same gumstix hardware. So
>> why its going to be different in palmtop and desktop builds??? Sakoman
>> has mentioned about formatting the uboot env nand partition for changing
>> the resolutions. Will that be a problem?
>>
>>
>> Edgardo Cruz wrote:
>>>
>>>>For 1. & 2., try a palmtop image.  Setting defaultdisplay to lcd35 seems
>>>>to override the resolution settings, so you shouldn't have to worry
>>>>about them.
>>>
>>>
>>> On 3/26/2010 1:57 PM, Anil Jacob wrote:
>>>> Hi,
>>>>
>>>> I tried the new gumstix overo fire board with Palo35 mother board and
>>>> used
>>>> the desktop build kernel form the branch hosted at
>>>> '/feeds/omap3/glibc/images/overo/201003190939'. Everything wass ok
>>>> except
>>>> for the LCD and wifi.
>>>>
>>>> My problems are,
>>>>
>>>> 1. LCD resolution is having some problems and the entire desktop is not
>>>> visible in the screen with edges clipped. Do anybody know a valid
>>>> resolution
>>>> for the LG 3.5" display which worked and which I need to set in the
>>>> uboot
>>>> parameters? Right now I am using the default display as LCD35 and
>>>> omafb.mode
>>>> as dvi:800x600-24@60 in the uboot parameters. Do I need to use video
>>>> instead
>>>> of dvi for the omapfb.mode?
>>>>
>>>> 2. Xlib says its not able to support the given resolution support once
>>>> in
>>>> the enlightenment desktop menu and when i try change the settings using
>>>> the
>>>> LCD/touch pad. Do I need to do something with xorg.conf for this?
>>>>
>>>> 2. Wifi is not getting the essid during the boot up time. Its taking
>>>> time ,
>>>> I think, for getting the connection with the AP. By that time, dhclient
>>>> will
>>>> end running up, without success in getting valid ip lease from the dhcp
>>>> server due to non availability of having a valid connection with AP. By
>>>> the
>>>> way I was able to connect it manually using wpa-supplicant and stuffs
>>>> and
>>>> get a valid dynamic address from dhcp server using dhclient from the
>>>> console
>>>> once I boots up.
>>>>
>>>> Any comments or updates?
>>>>
>>>> Regards,
>>>> Anil Jacob
>>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Download Intel&#174; Parallel Studio Eval
>>> Try the new software tools for yourself. Speed compiling, find bugs
>>> proactively, and fine-tune applications for parallel performance.
>>> See why Intel Parallel Studio got high marks during beta.
>>> http://p.sf.net/sfu/intel-sw-dev
>>> _______________________________________________
>>> gumstix-users mailing list
>>> gumstix-users@lists.sourceforge.net
>>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>>
>>>
>>
>>
>
>

--
View this message in context: http://old.nabble.com/LCD-and-wifi-problems-tp28046632p28627934.html
Sent from the Gumstix mailing list archive at Nabble.com.


------------------------------------------------------------------------------

_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users