Hooray, I got it.

I used the syntax 'iwconfig mwlan0 essid {NNN|any|on|off} txpower {NmW|NdBM|off|auto}', as it appears in /etc/network/interfaces.

It turns out that txpower is required (try 100mW). I tried first with essid any, then with my WAP's essid, and was successful both times. Try it and see if it works for you.

On 3/3/07, Alex <kb1fyr@gmail.com> wrote:
I'm having the same problem. I'm playing with it now, but I haven't made any progress.


On 3/2/07, Arnar Birgisson < arnarbi@gmail.com> wrote:
Hi there (again),

I hope nobody is getting tired of me.

I compiled the buildroot, mostly with the default settings and flashed
my gumstix 400xm.

I have a wifistix-cf, which was working fine with the shipped image,
but after the flash I get an error on iwconfig:

# iwconfig mwlan0 key xxxxxxxxxx key open essid ZyXEL_bEO txpower 100mW
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device mwlan0 ; Network is unreachable.


dmesg has this to say about it:

pccard: PCMCIA card inserted into slot 0
pcmcia: registering new device pcmcia0.0
cfio: module license 'unspecified' taints kernel.
Before register driver
Entering cf_attach()
pcmcia: request for exclusive IRQ could not be fulfilled.
pcmcia: the driver needs updating to supported shared IRQ lines.
BasePort1=0xc4860000, AssignedIRQ=49
After calling wlan_add_card function
After register driver

Do have to load any specific modules? I can see my AP if I run "iwlist scan".

Arnar

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users