I actually had this problem today on my Fedora system.
 
"yum install python-sqlite2" fixed the problem.  Sometimes when I have a problem like this I will run "yum uninstall python-sqlite2" and then run "yum install python-sqlite2".
 
Hope that helps.
 
For good measure, run this:
"yum install python m4 make wget curl ftp cvs monotone subversion tar bzip2 gzip unzip python-psyco ccache perl texinfo texi2html diffstat openjade docbook-style-dsssl docbook-style-xsl docbook-dtds docbook-utils sed bison bc glibc-devel gcc binutils pcre pcre-devel git quilt groff linuxdoc-tools patch linuxdoc-tools gcc gcc-c++ help2man python-pysqlite2 python-sqlite2"

Sincerely,
Thomas K. Bailey

K. Ronald Bailey & Associates Co. L.P.A.
220 West Market Street
P.O. Box 830
Sandusky, Ohio 44871-0830
Phone: 419-625-6740
Fax: 419-625-2021
www.baileyandassoc.com

-----Original Message-----
From: gumstix-users-bounces@lists.sourceforge.net [mailto:gumstix-users-bounces@lists.sourceforge.net]On Behalf Of Andrew MacIsaac
Sent: Sunday, January 06, 2008 1:02 PM
To: Gumstix Mailing List
Subject: [Gumstix-users] OE bitbake dependency error

Hi,

I am trying to build my first OE gumstix image, using the directions found here:

http://www.gumstix.net/Documentation/view/Getting-started/Setting-up-a-build-environment/29.html

My OS is CentOS 5, and I have installed all of the dependencies listed in these instructions, including psyco.  When I run

bitbake gumstix-basic-image

I get the following error:

ERROR: Importing sqlite3 and pysqlite2 failed, please install one of them. A 'python-pysqlite2' like package is likely to be what you need.

Since all of the packages that I can think of which might solve this (python, python-devel, sqlite3, python-sqlite) are already installed, I am not sure how to fix this.  Has anyone encountered this problem before, or has anyone successfully built an image on CentOS 5 or RHEL 5?


Thanks,

Andrew