I am having trouble following the various instructions about how to get audio working on the Verdex platform. Undoubtedly it is due to my being a newbie at both Linux and gumstix.  I am running a system based upon yesterdays sources.

 

I have run "modprobe -v snd-pxa2xx-ac97" and it seem to work as when I run "lsmod" I get:

 

Module                  Size  Used by

snd_pxa2xx_ac97         6348  0

snd_ac97_codec        102636  1 snd_pxa2xx_ac97

ac97_bus                1856  1 snd_ac97_codec

snd_pxa2xx_pcm          4640  1 snd_pxa2xx_ac97

snd_pcm                63397  3 snd_pxa2xx_ac97,snd_ac97_codec,snd_pxa2xx_pcm

snd_timer              19172  1 snd_pcm

snd                    45460  4 snd_pxa2xx_ac97,snd_ac97_codec,snd_pcm,snd_timer

soundcore               6116  1 snd

snd_page_alloc          5928  1 snd_pcm

ipv6                  248416  10

proc_gpio               9412  0

gumstix_bluetooth       1408  0

unix                   22292  8

 

 

However, when I run "brec >foo" gumsix reports "brec: /dev/dsp: No such file or directory"  Also, when I run "aplay -l" gumstix reports:

 

  **** List of PLAYBACK Hardware Devices ****

  ALSA lib control.c:817:(snd_ctl_open_noupdate) Invalid CTL hw:0

  aplay: device_list:231: control open (0): No such file or directory

  aplay: conf.c: 3108: snd_config_update_free: Assertion `update->count > 0 && update->finfo' failed.

  Aborted

 

What am I doing wrong?

 

TIA,

Rob't

 

 

 

 

 

 

 

Rob't

 

___________________________________________

Robert Blumberg

VoiceBox Technologies 
Embedded Software Engineer  (Contract)

11980 NE 24th Street

Bellevue WA  98005

425 968 7949

RobertB@VoiceBox.Com