Thanks for the info.  I had done "mv root root.old; mkdir root" and should have just skipped the mkdir.  My system is still not doing /sbin/init properly and  all the "experiments" I'm doing to  attempt to correct  things are just digging me into deeper and irrelevant holes inadvertently (although I'm learning to avoid pilot errors).

I really need to trace what /sbin/init is doing (wrong).  I just built rev 1489 with a bare-bone .config and it still won't run.

On 8/1/07, Dave Hylands <dhylands@gmail.com> wrote:
Hi Peter,

On 8/1/07, Peter Lu <plu777@gmail.com> wrote:
> Sorry, it looks like stuff in /etc just doesn't get re-created if
> build_am_nofpu/root is cleared out (for a "clean" build of the target FS).
> I managed to retrieve most of the config files, but /sbin/init still doesn't
> do much.  I need to do printk's in /sbin/init to see what it is really
> doing.

Try doing

cd gumstix-buildroot/build_arm_nofpu
rm -rf root

There is a file called gumstix-buildroot/target/generic/skel.tar.gz
which gets expanded and copied into the root directory, but only if
the root directory itself doesn't exist.

Dave Hylands
Vancouver, BC, Canada

This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>   http://get.splunk.com/
gumstix-users mailing list