Hello:

I have gotten further this time around but I'm not done yet.

Here is my original posting
http://sourceforge.net/mailarchive/message.php?msg_id=15565232

To which I received the following instructions
http://sourceforge.net/mailarchive/message.php?msg_id=15573402
http://sourceforge.net/mailarchive/message.php?msg_id=15574788

I couldn't get it to work so I posted again
http://sourceforge.net/mailarchive/message.php?msg_id=15576955

and now I have made some progress:

I got STEP 1 to work.

STEP 1-Creating the /dev/input/event0 in the gumstix
  Follow the instructions here:
   http://sourceforge.net/mailarchive/message.php?msg_id=14681623
 
  If you need help with the key sequence read this:
   http://sourceforge.net/mailarchive/message.php?msg_id=14688498

  Note:
  if pwd gives you an error then try this: (it worked for me)
  #make ARCH=arm CROSS_COMPILE=/home/gumstix-buildroot/build_arm_nofpu/staging_dir/bin/arm-linux- menuconfig 
  and  
  #make ARCH=arm CROSS_COMPILE=/home/gumstix-buildroot/build_arm_nofpu/staging_dir/bin/arm-linux-

  Note:
  After reflashing your gumstix, if you check /dev,  you will not find a /dev/input directory.
  It will appear only after you have typed these commands on your gumstix:
 
  #modprobe snd-pxa2xx-ac97
  #modprobe ucb1x00-ts
  #modprobe evdev

  The instructions tell you to do this, but it was not obvious to me that there wouldn't be
  a /dev/input directory until you executed the commands above

So now I got this to work so I moved on to step 2

STEP 2 - building TSLIB (patching the kernel for touchscreen support)
 I downloaded the tslib.tar.gz from http://www.realfafard.com/fafard/index.php?id=31
 I unpacked it to the /home/gumtix-buildroot/build_arm_nofpu/package/tslib
 I edited Config.in in /home/gumtix-buildroot/build_arm_nofpu/package/ and I added  the 'source /package/tslib/Config.in' entry.

 then I ran 'make menuconfig' from /home/gumtix-buildroot, I went to packages and I selected tslib.
 This did not work because I did not have CVS, so I did a 'apt-get install cvs' then I tried again
 During the configuration of TSLIB, I was asked the name of the file to patch so I typed:
 '/home/gumstix-buildroot/build_arm_nofpu/tslib/configure.ac'

 This is what I get now: an error because of a missing application

CFLAGS="-Os -pipe -Os -march=armv5te -mtune=xscale -Wa,-mcpu=xscale  " \
./configure \
--target=arm-linux \
--host=arm-linux \
--build=i386-pc-linux-gnu \
--prefix=/home/gumstix-buildroot/build_arm_nofpu/staging_dir/usr );
./autogen.sh: line 4: autoreconf: command not found
/bin/sh: line 1: ./configure: No such file or directory
make: *** [/home/gumstix-buildroot/build_arm_nofpu/tslib/.configured] Error 127
colinux:/home/gumstix-buildroot#

It seems I do not have this autoreconf application. I tried to do an 'apt-get install autoreconf' but the file was not found.

so I fetch 'apt-get install autoconf' then I get a little furter but I get another set of errors:

CFLAGS="-Os -pipe -Os -march=armv5te -mtune=xscale -Wa,-mcpu=xscale  " \
./configure \
--target=arm-linux \
--host=arm-linux \
--build=i386-pc-linux-gnu \
--prefix=/home/gumstix-buildroot/build_arm_nofpu/staging_dir/usr );
Can't exec "aclocal": No such file or directory at /usr/bin/autoreconf line 176.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 17
6.
Can't exec "automake": No such file or directory at /usr/bin/autoreconf line 177
.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 17
7.
Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/
FileUtils.pm line 288.
autoreconf: failed to run aclocal: No such file or directory
/bin/sh: line 1: ./configure: No such file or directory
make: *** [/home/gumstix-buildroot/build_arm_nofpu/tslib/.configured] Error 127
colinux:/home/gumstix-buildroot#

Again,

Thanks for all your help, I'm hoping this post will clarify a few more of the steps involved

Best Regards,

Yerko Alfonso