Chrissy,

You probably have a symlink somewhere in/under your <gumstix-oe> directory, which you can't have with the OE build system.  Search the list archives for 'libtool-native' for more details.

Chris

On Wed, May 28, 2008 at 6:40 PM, Chrissy Murray <gossamurr22@yahoo.com> wrote:
Hello,
I'm new to gumstix, and I'm trying to do the gumstix-basic-image build.  When I do this, I get an error in libtool-native-1.5.10-r6.  It spits out the attached logfile.  The problem appears to boil down to the following logfile snippet:
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: error: source directory already configured; run "make distclean" there first
make[1]: *** [i686-linux-libtool] Error 1
make[1]: Leaving directory '~/gumstix/gumstix-oe/tmp/work/i686-linux/libtool-native-1.5.10-r6/libtool-1.5.10'
make: *** [all-recursive] Error 1
FATAL: oe_runmake failed
I tried running a "make distclean" in the ~/gumstix/gumstix-oe/tmp/work/i686-linux/libtool-native-1.5.10-r6/libtool-1.5.10' directory.  However, the "distclean" option was not recognized (this means I'm probably running it in the wrong spot...).  I ran a "make clean" hoping that this would help.  However, I got the same error when I re-ran the build.
I checked ahead in the documentation and ran the following recommended command: "rm -rf ~/gumstix/gumstix-oe/tmp".  However, I still got the same error when I re-ran the build.
Finally, I deleted everything and started over from the beginning of the instructions on setting up the build environment.  I still got the same error.
Has anybody else run into this problem and worked through it?  Does anyone have any ideas for getting around this problem?
Thanks,
Chrissy


     

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users