Hi Jack,
 
Thanks for the response.  Yes, I tried using the latest version of buildroot (1585).  I will try again using a different version of buildroot to see if that works for me.  Does anyone know why the latest version has a problem with this procedure?
 
Thanks,
Jason

 
On 2/13/08, Jack Noble <jack.h.noble@vanderbilt.edu> wrote:
Hi Jason,

Are you using the buildroot?  I compiled V4L and pwc about a week or two
ago, but I couldn't get it to work using the latest buildroot. When I
reverted to 1533 everything worked smoothly. As you said previously, I
just did  "make menuconfig ARCH=arm" in the linux-2.6.21gum directory,
enabled V4L and pwc. Then I did "make ARCH=arm
CROSS_COMPILE=/.../staging_dir/bin/arm-linux-" in the linux-2.6.21gum
directory to build the linux kernel and generate the ko files --
although I am unsure whether the cross_compile bit is necessary.




> Date: Tue, 12 Feb 2008 21:17:08 -0800
> From: "Jason Gordon" <jgordon20@gmail.com>
> Subject: [Gumstix-users] Video4Linux
> To: "General mailing list for gumstix users."
>       <gumstix-users@lists.sourceforge.net>
> Message-ID:
>       <55d1bb920802122117h5c0701d1hb76a71a568ec4cd3@mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi,
>
> I'm trying to setup video4linux on my verdex as described in
> http://docwiki.gumstix.org/Video4linux, but am having some problems.  The
> first problem is there is no
>
> --> Multimedia devices --> Video Capture Adapters --> V4L USB Devices
> --> GSPCA (Generic Software Package for Camera Adaptors)
>
> option after doing "make ARCH=arm menuconfig" in the
> gumstix-buildroot/build_arm_no_fpu/linux-2.6.21gum directory.  I tried
> enabling the USB Philips Cameras option (as well as some other options)
> instead but no *.ko file was built after I went back to the
> gumstix-buildroot directory and did "make ARCH=arm".  The bottom line is I
> can't seem to generate any *.ko files in the
> linux-2.6.21gum/drivers/media/video/pwc
> directory as explained on the wiki no matter what I enable after doing "make
> ARCH=arm menuconfig" in the linux-2.6.21gum directory.  Has anyone else run
> into this problem?  Could someone please tell me what I am missing here?
>
> Thanks,
> Jason



--

____________________________________________________

Jack H. Noble
Vanderbilt University
Dept. of Electrical Engineering and Computer Science
Nashville, TN
____________________________________________________


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users