Hi James,
    Yes with the latest open-embedded package, iam also getting this problem.

But following package are build successfully
bitbake ti-dsplink-module

But the following packages are not able to build
bitbake ti-codec-eninge and
bitbake ti-cmem-module

log information

nand@build:bitbake ti-cmem-module
NOTE: Handling BitBake files: \ (8394/8394) [100 %]
Parsing of 8394 .bb files complete (7934 cached, 460 parsed). 8329 targets, 318 skipped, 1 masked, 0 errors.
Unknown Event: <bb.event.NoProvider instance at 0x108d136c>
ERROR: Nothing PROVIDES 'ti-cmem-module'
Command execution failed: Traceback (most recent call last):
  File "/media/500_p4/open_embedded/overo-oe/bitbake/lib/bb/command.py", line 88, in runAsyncCommand
    commandmethod(self.cmds_async, self, options)
  File "/media/500_p4/open_embedded/overo-oe/bitbake/lib/bb/command.py", line 174, in buildTargets
    command.cooker.buildTargets(pkgs_to_build, task)
  File "/media/500_p4/open_embedded/overo-oe/bitbake/lib/bb/cooker.py", line 782, in buildTargets
    taskdata.add_provider(localdata, self.status, k)
  File "/media/500_p4/open_embedded/overo-oe/bitbake/lib/bb/taskdata.py", line 354, in add_provider
    self.add_provider_internal(cfgData, dataCache, item)
  File "/media/500_p4/open_embedded/overo-oe/bitbake/lib/bb/taskdata.py", line 383, in add_provider_internal
    raise bb.providers.NoProvider(item)
NoProvider: ti-cmem-module


Did you came across this problem ? Any solution for this ?

Thanks and regards,
Ananth

James McColl wrote:
Hi all,

I am a college student developer and I doing a project that requires the DSP on the overo fire.  After three days of work I finally have open embedded up (and can interface with board via ethernet), and after following the pixhawk tutorial have ti-dsplink-module and ti-codec-engine compile but not depolyed.  the final piece to this prize before development is getting the cmem-module to compile.  Everytime I use the bitbake ti-cmem-module command (from the normal command terminal user or from the oe directory in the source build/profile overo) I get these errors:

OE:overo laptop1@laptop1-laptop:~/overo-oe$ bitbake ti-cmem-module
NOTE: Handling BitBake files: | (8404/8404) [100 %]
NOTE: Parsing finished. 7626 cached, 460 parsed, 318 skipped, 1 masked.
ERROR: Nothing PROVIDES 'ti-cmem-module'


or

ERROR: no such table: BB_URI_LOCALCOUNT while parsing /home/laptop1/overo-oe/org.openembedded.dev/recipes/linux/linux-openmoko-devel_git.bb
NOTE: Handling BitBake files: - (8395/8395) [100 %]
NOTE: Parsing finished. 0 cached, 7833 parsed, 293 skipped, 1 masked.
ERROR: Parsing errors found, exiting...

I am completely out of ideas and will take any advice I can get.  The reason I need this is to get the DSPlink toolchain working so I can compile my own code.  Write now when I try to compile one of the samples I get this error:

/home/laptop1/cross/armv7a/bin/../lib/gcc/arm-angstrom-linux-gnueabi/4.3.3/../../../../arm-angstrom-linux-gnueabi/bin/ld: cannot find cmem.o
collect2: ld returned 1 exit status
make[2]: *** [messagegpp.deb] Error 1
make[1]: *** [trgdeb] Error 2
make: *** [message.trgdeb] Error 2


Thanks in advance!

-Jim



------------------------------------------------------------------------------

_______________________________________________ gumstix-users mailing list gumstix-users@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/gumstix-users