Yeah, I did try to download the package from the URL, only problem is the packages seem to be missing from the Debian site and the Gumstix site.  There are different versions of packages you can download, but just not the specific version that Buildroot wants.  Maybe just use a newer version package? 

 


From: gumstix-users-bounces@lists.sourceforge.net [mailto:gumstix-users-bounces@lists.sourceforge.net] On Behalf Of Jayesh Salvi
Sent: Friday, May 25, 2007 9:48 AM
To: General mailing list for gumstix users.
Subject: Re: [Gumstix-users] Buildroot packages and bugs

 

Have you tried extracting the URL that is fed to wget? You can find what you get when you download from that URL using firefox or wget? If it's a bug with wget, you will get correct version from firefox.

Jayesh

On 5/22/07, Dave Scott <dscott@fibersphere.com> wrote:

Hi all, I'm new to my Gumstix,

 

I successfully compiled the default config of Gumstix, however when I start adding packages, the problems start happening.  Is it normal to get a lot of errors when adding packages? 

 

For instance, there are a lot of packages that seem to be missing, the Debian dl site and the alternative files.gumstix.org site both are missing the packages.  It's as if the Buildroot was built with a certain package but then the package maintainer removes the correct package.  Maybe archiving all the packages somewhere for each version of Buildroot would help?  Is there another mirror of the correct packages?

 

The other problem I'm having is I seem to be getting a ton of errors on compiles, like for instance if I add the nmap package and compile, I get the following error.

 

11:05:43 (155.55 KB/s) - `/home/dave/gumstix-buildroot/dl/nmap-4.20.tgz.1' saved [2704981/2704981]

zcat /home/dave/gumstix-buildroot/dl/nmap-4.11.tgz | tar -C /home/dave/gumstix-buildroot/build_arm_nofpu   -xf -

zcat: /home/dave/gumstix-buildroot/dl/nmap-4.11.tgz: No such file or directory

toolchain/patch-kernel.sh /home/dave/gumstix-buildroot/build_arm_nofpu/nmap-4.11 package/nmap nmap*.patch

Aborting.  '/home/dave/gumstix-buildroot/build_arm_nofpu/nmap-4.11' is not a directory.

make: *** [/home/dave/gumstix-buildroot/build_arm_nofpu/nmap-4.11/configure] Error 1

 

 

So, looks like Buildroot wants to use nmap-4.11.tgz, but the downloader downloaded version 4.20.

 

Is this a bug?

 

These errors go on and on, so far, I've been unsuccessful using my Gumstix for much more than the default build.  The Wiki does not show anything on how to get around the package problems and compile errors. 

 

Am I the only one having these problems?

 

Thanks for all your kind help.

Dave

 


-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users