Hi Dave,

well, seems the cat to /dev/ttyS2 doesnt cut it...
using sertest as is gave the data, (set it to 4800 baud, but not worked, 9600 seems to be ok)
I am using a passive antenna, and as per the gpsstix im in the middle of the sea right now, which dist as much as 1000 Km i guess from where i am. Ued the http://www.gonmad.co.uk/nmea.php to see the map
Take a look yourself if you want:
$GPRMC,230441.00,A,3453.25858,S,05609.63504,W,1.629,221.70,060906,,,A*6F
$GPVTG,221.70 ,T,,M,1.629,N,3.018,K,A*3D
$GPGGA,230441.00,3453.25858,S,05609.63504,W,1,05,1.59,52.8,M,10.8,M,,*60
$GPGSA,A,3,20,24,13,16,27,,,,,,,,3.04,1.59,2.59*02
$GPGSV,3,1,11,04,32,239,,23,62,167,15,20,65,074,31,24,46,260,27*72
$GPGSV,3,2,11,13,53,240,24,25,08,137,,02,06,216,,16,23,097,15*7B
$GPGSV,3,3,11,08,03,327,,27,27,325,24,11,11,002,*44
$GPGLL,3453.25858,S,05609.63504,W,230441.00,A,A*6B
$GPZDA,230441.00,06,09,2006,00,00*6D

I guess im getting less than 4 satellites provided the big error.
Do you think should i try go active antenna?, in the city its always been a prob getting a good signal, but not like what i am getting...
maybe i live in a forgotten area of the globe or something ;)
thanks for the heads up

Rodrigo

On 9/6/06, Dave Hylands <dhylands@gmail.com> wrote:
Hi Rodrigo,

On 9/6/06, Rodrigo Sosa <rodrigososa@gmail.com> wrote:
> Hi all,
>
> Can somebody here with a GPSstix copy a few lines from the output of doing
> cat /dev/ttyS2 ?

You can find a file captured from ttyS2 over here:
http://www.davehylands.com/Misc/gps/nmea-abbrev.log

You should see something like this:
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,00*79
$GPGLL,,,,,,V,N*64
$GPZDA,,,,,00,00*48
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,00,99.99,,,,,,*48
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,00*79
$GPGLL,,,,,,V,N*64
$GPZDA,,,,,00,00*48

when you first power on the board. The contents of the strings change
as satellites are acquired.

> I ve been trying to see any data from it, but all i have is
> ���xx<��x<��x�xx��������x���x���x��x<x�x�x�x�x�x�x������x������x�x�x���x�x<�����x<��x���xx<�x
> <x<�xx�x�x�x�x�x�x�x�x���x�x<�����x��x���xx<�x�x<xx��������x���x���x�x�x�x�x��x���
> x�x��x���x�x��x��x�x�x�x�x�x��x<����x��x��x���xx<�x��x<xx�xx
> and so on...

You're probably not set at 4800 baud.

--
Dave Hylands
Vancouver, BC, Canada
http://www.DaveHylands.com/
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users