I had the filesystem om gumstix working nicely but It was a very big filesystem
leaving me with just about 1 meg of "disk" space for my programs.
So having a little time before Xmas I decided to rebuild buildroot to make it
smaller. This I did but the WiFi doesn't work when I load it on to the gumstix.
It seems probable that I just haven't enabled a required option but I have
all the ones that noted before RPC WiFi etc.
Any Ideas?
The following are errors I get on reboot most of which I didn't get before

Dec 31 16:00:10 udhcpc[179]: [truncated] m
cfio: module license 'unspecified' taints kernel.
cfio: Unknown symbol pcmcia_disable_device
cfio: Unknown symbol pcmcia_unregister_driver
cfio: Unknown symbol pccard_get_first_tuple
cfio: Unknown symbol pcmcia_get_configuration_info
cfio: Unknown symbol pcmcia_request_io
cfio: Unknown symbol pcmcia_request_configuration
cfio: Unknown symbol pcmcia_access_configuration_register
cfio: Unknown symbol pccard_get_tuple_data
cfio: Unknown symbol pcmcia_register_driver
cfio: Unknown symbol pccard_parse_tuple
cfio: Unknown symbol pcmcia_request_irq
Dec 31 16:00:10 modprobe: WARNING: Error inserting cfio (/lib/modules/2.6.21gum/extra/cfio.ko): Unknown symbol in module, or unknown parameter (see dmesg)

mcf25: Unknown symbol cfio_read_cfg_reg
mcf25: Unknown symbol pccard_get_first_tuple
mcf25: Unknown symbol cardp
mcf25: Unknown symbol cfio_dev_info
mcf25: Unknown symbol pccard_get_tuple_data
mcf25: Unknown symbol register_cf_driver
mcf25: Unknown symbol pccard_get_next_tuple
mcf25: Unknown symbol unregister_cf_driver
Dec 31 16:00:10 modprobe: FATAL: Error inserting mcf25 (/lib/modules/2.6.21gum/extra/mcf25.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Thank you

John Cummins

Never miss a thing. Make Yahoo your homepage.