Hello,

I got a new microSD card and it turns out that the original card was a dud ... so I fired up gparted again and got everything put where it needed to be ... at least I thought I did, but when I boot now I get the following set of messages during boot:

mmcblk0: mmc0:1234 SA02G 1927168KiB
  mmcblk0: p1 p2
.
.
.
root: mount: special device /dev/mmcblk0p1 does not exist
.
.
.
FAT: Invalid media media value (0x00)
VFS: Can't find a valid FAT filesystem on mmcblk0

And then it continues to boot using the original rootfs in Gumstix memory.

If I run fdisk on mmvblk0 I get:

Disk /dev/mmcblk0: 1973 MB, 1973420032 bytes
255 heads, 63 sectors/track, 239 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

        Device Boot    Start       End    Blocks   Id  System
/dev/mmcblk0p1   *           1           8       64228+   6  FAT16
/dev/mmcblk0p2               9         239     1855507+  83  Linux

Or if I run fsch on it:

fsck 1.38 (30-Jun-2005)
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
/dev/mmcblk0p1: 3 files, 489/32042 clusters

The only 'weird' thing is that when I ran mkfs.cfat I used the -F 16 flag so it would be fat16 but it show up as f32 ???

I saw one or two messages that talked about this problem, but never with a resolution.  Any ideas on what is causing this?

Respectfully,

Sean Stallbaum

Serena Software, Inc. | Sr. Technical Consultant
E: SStallbaum@serena.com | P: 216-374-9195
Sent from Lakewood, Ohio, United States