I am following the instructions for setting up the OE environment for my Gumstix Verdex Pro and am running into problems getting bitbake to run.  This is my 1st attempt at getting back into real programming, I haven't beein infront of a linux termonal in 5 years and am a bit rusty ;)

I am in the process of double checking my paths to make sure everything looks right, ... the problems I am having are:
  1. bitbake doesn't run unless i provide the full path .. I know that it should be setup in the PATH env and it is ... see here  ->PATH=/home/sean/gumstix/gumstix-oe/bitbake/bin:/home/sean/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games.  BitBake is located in the /home/sean/gumstix/gumsticx-oe/bitbake/bin directory and has 777 access and I am owner of everything.
  2. When I do get BitBake to run, it complains about not being able to open 'conf/bitbake.conf'.  It is in the BBPath ->  /home/sean/gumstix/gumstix-oe/build:/home/sean/gumstix/gumstix-oe/user.collection:/home/sean/gumstix/gumstix-oe/com.gumstix.collection:/home/sean/gumstix/gumstix-oe/org.openembedded.snapshot.  In doing some more poking around, I found that the version sitting in the org.openembedded.snapshot is decidedly different that the one in the bitbake directory ... which is correct one to be referencing?
I am running Ubuntu 9.04 to connect to the gumstix. I am wondering if that is a 'good' flavor of Linux to be using?  Is there a 'better' flavor to use?

Respectfully,

Sean Stallbaum

Serena Software, Inc. | Sr. Technical Consultant
E: SStallbaum@serena.com | P: 216-374-9195