Hi,

Here is the information about my gumstix's network setup.  Could someone please tell me how to get my ethernet to work?

I am pretty desperate right now.

thanks,
jb



root@overo:~# /etc/init.d/networking start
Configuring network interfaces... ifup: interface lo already configured
ifup: interface eth0 already configured
done.
root@overo:~# ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:40 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2880 (2.8 KiB)  TX bytes:2880 (2.8 KiB)

root@overo:~# cat /etc/in
/etc/init.d/  /etc/inittab  /etc/inputrc
root@overo:~# cat /etc/network/i
/etc/network/if-down.d/       /etc/network/if-up.d/
/etc/network/if-post-down.d/  /etc/network/interfaces
/etc/network/if-pre-up.d/
root@overo:~# cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
 
# The loopback interface
#
auto lo
iface lo inet loopback

#
# Wired interfaces
#

auto eth0
iface eth0 inet dhcp
iface eth1 inet dhcp

#
# Wireless interfaces
#

# Example of an unencrypted (no WEP or WPA) wireless connection
# that connects to any available access point:
#
allow-hotplug wlan0
iface wlan0 inet dhcp
        wireless_mode managed
        wireless_essid any

# Example of an unencrypted (no WEP or WPA) wireless connection
# that is locked to a specific access point:
#
#iface wlan0 inet dhcp 
#       wireless_mode managed
#       wireless-essid some-essid

# Example of a WEP encrypted connection locked to a specific access point:
#
#iface wlan0 inet dhcp 
#  pre-up /sbin/iwconfig $IFACE key 03AB30A4EF8A71A4781DA1CB84 key open essid gW

# Example of a WPA1 or WPA2 encrypted connection locked to a specific access po.
#
# You will also need to create a /etc/wpa_supplicant.conf file:
#  Copy / paste the results of this command into that file :
#     wpa_passphrase myssid mypasswordhere
#
#iface wlan0 inet dhcp
#      pre-up wpa_supplicant -Dmarvell -iwlan0 -c/etc/wpa_supplicant.conf -Bw
#      down killall wpa_supplicant         

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
iface usb0 inet static
        address 192.168.0.202
        netmask 255.255.255.0
        network 192.168.0.0
        gateway 192.168.0.200

# Bluetooth networking
iface bnep0 inet dhcp



On Sun, Sep 20, 2009 at 3:40 PM, Juan Backson <juanbackson@gmail.com> wrote:
Hi,

I have tobi and gumstix fire.  I am able to boot up Angstrom, but Internet connection from tobi's ethernet port is still not working.

Does anyone know what I need to do to get it to work?

thanks,
jb