Are you changing any of the configuration or are you just using the defconfig?

I get the exact same error when I try to make the latest buildroot configured with gcc 3.4.5 instead of gcc 4.x. I need the toolchain to be 3.4.5 to avoid the "Unhandled fault: imprecise external abort ... Bus Error" described here: http://sourceforge.net/mailarchive/message.php?msg_id=37778543 . But it builds fine if I use the defconfig.

-RobB

On 1/11/07, EXT-McGhehey, Mark J <Mark.J.McGhehey@boeing.com > wrote:
I have been trying to build one of the more recent buildroots (i.e.
1206, 1211, etc....), but the build always fails in the uClibc section.
I am building the buildroot environment from scratch, not just upgrading
from an existing buildroot.

  I get lots of compile warnings all throughout the uClibc section but
then the build finally stops with this erorrs:

      LD libuClibc-0.9.29.so
    libc/libc_so.a(ioperm.os): In function '__GI_ioperm':
    ioperm.c:(.text_0x2e4): undefined reference to '__guard'
    make[2]: ***[lib/libc.so] Error 1
    make[1]: ***[lib/libc.so] Error 2

  Has anyone seen and/or already resolved this one?

Thanks

~~~~~~~~~~~~~~~~~~~~~~~~~
Mark McGhehey
The Boeing Company

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users