I have it working as a 2cd login.  This is what i added to my inittab.
 
ttyS3::respawn:/sbin/getty -L ttyS3 115200 vt100
David.

Kim Hendrikse <kim@kiwiclan.com> wrote:
I'm just installed a new (Old style) gumstix and I don't seem to be able
to get the HWUART working like I did on the other gumstix I had. With the
other one, I simply went

stty 38400 < /dev/ttyS3
cat < /dev/ttyS3

and I could read from it. That's not working for me now. The kernel
details are:

2.6.7-gnalm0-gum0-craig #1

and

dmesg|fgrep -i tty

yields:

# dmesg|fgrep -i tty
Kernel command line: console=ttyS0,115200n8 root=1f02 rootfstype=jffs2 reboot=co
ld,hard
ttyS0 at MMIO 0x40100000 (irq = 15) is a FFUART
ttyS1 at MMIO 0x40200000 (irq = 14) is a BTUART
ttyS2 at MMIO 0x40700000 (irq = 13) is a STUART
ttyS3 at MMIO 0x41600000 (irq = 0) is a HWUART
Bluetooth: RFCOMM TTY layer initialized

Note, this is an old style stix without bluetooth. What's changed? How
can I get the HWUART working again?

- Kim


-------------------------------------------------------
This SF.Net email is sponsored by OSTG. Have you noticed the changes on
Linux.com, ITManagersJournal and NewsForge in the past few weeks? Now,
one more big change to announce. We are now OSTG- Open Source Technology
Group. Come see the changes on the new OSTG site. www.ostg.com
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users


Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!