The blue light (on my Overos) turns on when the mmc transceiver is detected by u-boot.  It turns regardless of whether a uSD card is actually inserted.

I would connect via the serial console, and inspect the u-boot console output.   This will let you know if u-boot is not loading at all,  if u-boot is working, but the mmc transceiver is not being detected, or if the transceiver is detected, but the LED isn't lighting for some other reason.

Greg





From: pg <pg_96@me.com>
To: gumstix-users@lists.sourceforge.net
Sent: Friday, April 27, 2012 6:06 AM
Subject: Re: [Gumstix-users] IronSTORM COM not fully booting

Bump.

I think I need to clarify,

I connect power to my Gumstix with a bootable micro SD card plugged in.
Except only the green light turns on, meaning it is not reading the SD card
because the blue light is not illuminating, thus, not fully booting.

--
View this message in context: http://gumstix.8.n6.nabble.com/IronSTORM-COM-not-fully-booting-tp4931917p4933863.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users