Hi,
   
       After several weeks work,I succeeded in following the helloworld example posted at http://www.gumstix.org/software-development/open-embedded.html
and get "helloworld-dbg_0.0-r0.6_armv5te.ipk  helloworld_0.0-r0.6_armv5te.ipk helloworld-dev_0.0-r0.6_armv5te.ipk" files.Then I logged in gumstix and typed
./helloworld_0.0-r0.6_armv5te.ipk
and got
Syntax error: newline unexpected
I tried
ipkg install helloworld_0.0-r0.6_armv5te.ipk
and confronted with
ERROR: Cannot satisfy the following dependencies for helloworld:
     libc6 (>= 2.9)
I tried opkg but not installed
so wish some help
thanks