We are loathe to reflash our gumstix, could you advise how we would go about changing to use uClibc 0.9.27 to build i2c? 
Thanks,
Adrian

On 4/7/06, Dave Hylands <dhylands@gmail.com> wrote:
Hi Adrian,

On 4/7/06, Adrian S. Laney <adrian@adrianlaney.com> wrote:
> I am trying to use the i2c program to test my MG1101 microgyro.  I compiled
> it without errors for my kernel ( 2.6.11), but any time I try to run it on
> the gumstix I get "Segmentation fault".

This normally means that buildroot that you're using doesn't match the
version of rootfs that's on your phone. The latest 2.6.11 is revision
773.

The real problem is that uClibc that was shipped with the 2.6.11
kernels is 0.9.27 and the uClibc that's shippeed with the newer
kernels is 0.9.28. Trying to run an executable built against 0.9.28 on
a gumstix running 0.9.27 causes a segmentation fault.

--
Dave Hylands
Vancouver, BC, Canada
http://www.DaveHylands.com/


-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmdlnk&kid0944&bid$1720&dat1642
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users