Hi Cyril,
 
Yes The bluez works perfect. Itīs compilated and all utils are in the module.
 
I am sure that the error is stupidity of the configuration.
 
For the moment, Itīs wins   Sir Graham 0   GumStix 1
 
I hope I find the problem soon.
 
Thanks for you help.
 
Regards,
Sir Graham.
 
----- Original Message -----
From: Cyril Bazin
To: gumstix-users@lists.sourceforge.net
Sent: Monday, July 18, 2005 10:54 PM
Subject: Re: [Gumstix-users] problems second serial port of gumstix....

Are you sure craig didn't compile "bluez-utils" with specials options?
Have a look at the file named "bluez.mk" in the directory "make" of the buildroot... It can be there.

Your gumstix will work well step by step, it's a matter of patience!
It cost us months to make all the serial ports and the sound working well!

Cyril

On 7/18/05, Sir Graham (Terra) <grahamsir@terra.es> wrote:
Hi Cryril,
 
Yes. You scripts works. But now there is other problem. If the bluetooth script S30bluetooth is executed in the boot the ttyS3 donīt work.
 
We try to rename the S99SpecialConfig to S29SpecialConfig to execute before the S30bluetooth but the results is the same.
If we rename the S30bluetooth to s30bluetooth (desactivate this script) the /dev/ttyS3 works perfect.
 
The case is that we need the ttyS3 to connect a serial bluetooth module (support by Bluez) in H4 format (noflow). In the Red Hat this module works
perfect but in the gumstix we donīt know how the S30bluetooth must be configurated.
 
Any idea....?
 
Regards,
Sir Graham.
 
 
----- Original Message -----
Sent: Monday, July 18, 2005 7:46 PM
Subject: Re: [Gumstix-users] problems second serial port of gumstix....



On 7/18/05, Sir Graham (Terra) <grahamsir@terra.es> wrote:
Hi Cryril,
 
Here you are.
 
# cat /proc/gpio/GPIO4[6789]
46      GPIO    in      set
47      GPIO    in      set
48      AF2     in      set
49      AF2     out     set

Very bad!
Neither ttyS2 nor ttyS3 are configured correctly!
It's normal that you don't have anything on your output
 
The correct configuration would be:

# cat /proc/gpio/GPIO4[6789]
46      AF2    in     ...
47      AF1    out      ...
48      AF1    out      ...
49      AF1    in     ...

The GPIO 46-47 are for ttyS2, 48-49 are for ttyS3.

Set them all correctly using the magic formula:

modprobe proc_gpio

echo "AF2 in" >/proc/gpio/GPIO46
echo "AF1 out" >/proc/gpio/GPIO47
stty -F /dev/ttyS2 -ixon speed 115200

echo "AF1 out" >/proc/gpio/GPIO48
echo "AF1 in" >/proc/gpio/GPIO49
stty -F /dev/ttyS3 -ixon speed 115200

A better approach is to create a file in "/etc/init.d"  named  "S99SpecialConfig" with the following content:

#------------------------------------------------------------
#
# Special config
#

start() {
    modprobe proc_gpio
        echo "AF2 in" >/proc/gpio/GPIO46
        echo "AF1 out" >/proc/gpio/GPIO47
        stty -F /dev/ttyS2 -ixon speed 115200

        echo "AF1 out" >/proc/gpio/GPIO48
    echo "AF1 in" >/proc/gpio/GPIO49
    stty -F /dev/ttyS3 -ixon speed 115200
}

stop() {
}

restart() {
        stop
        start
}

case "$1" in
  start)
        start
        ;;
  stop)
        stop
        ;;
  restart|reload)
        restart
        ;;
  *)
        echo $"Usage: $0 {start|stop|restart}"
        exit 1
esac

exit $?
#-------------------------------------------------

That what we  made  on our gumstix and it work perfectly. Since that, we don't worry about ttyS*.

Don't hesitate to tell us if it works or not. But, it should work.
If it doesn't verify the state of your GPIOs.

>  we have the Build 516. Where are the configuration of the Second port, what is this configuration... and Why donīt work like the the first port?

That's a classical GPIO  problem, the processor of the gumstix : Intel PXA255 can do different things using the same input/output.
For example, it can do bluetooth I/O or Serial I/O on the same connector. So, you need to configure by hand if you want the first or the second.

We will connect a bluetooth module to the second port.... We try this module in a red hat with bluez and works perfect. But I canīt configurate
the second port to works with bluez.... ŋ?

After looking at your GPIO configuration the verdict is: Hopefully, it doesn't work! Else the problem would be very strange.
To test, you should try to communicate with a PC using hyperterminal or minicom.

Regards,
Sir Graham.
----- Original Message -----
Sent: Monday, July 18, 2005 1:55 PM
Subject: Re: [Gumstix-users] problems second serial port of gumstix....

Could you show us a copy of the state of your GPIO?

From memory, use this command:

cat /proc/gpio/GPIO4[6789]

And a copy of the state of your ttys (from /proc/driver/...) before and after sending these commands:

echo "FooBarBaz" >/dev/ttyS2
echo "FooBarBaz" >/dev/ttyS3

Cyril

On 7/15/05, Sir Graham (Terra) <grahamsir@terra.es> wrote:
Hi Cyril,
 
This not work too.  
 
Hwat happend with the second port of Serial ? any of this works.....
 
Regards,
Sir Graham.
 
----- Original Message -----
Sent: Friday, July 15, 2005 2:02 PM
Subject: Re: [Gumstix-users] problems second serial port of gumstix....

I fogot that we added the patch for ttyS3  (look at  http://www.gumstix.org/tikiwiki/tiki-index.php?page=Tips+and+Tricks#attachments )

On 7/15/05, Cyril Bazin <cyril.bazin@gmail.com > wrote:
Hello,

To configure the serial port ttyS2 and ttyS3, we used these command:

modprobe proc_gpio

echo "AF2 in" >/proc/gpio/GPIO46
echo "AF1 out" >/proc/gpio/GPIO47
stty -F /dev/ttyS2 -ixon speed 115200

echo "AF1 out" >/proc/gpio/GPIO48
echo "AF1 in" >/proc/gpio/GPIO49
stty -F /dev/ttyS3 -ixon speed 115200

(Replace the speed )

For more informations about GPIO, read "http://www.intel.com/design/pca/prodbref/252780.htm " around the page 107.

Cyril


On 7/15/05, Florian Loitsch < gumstix@florian.loitsch.com > wrote:
Verify the configuration of the relevant GPIOs too. From r374 on they should
be set to uart, but before you had to do it manually (see the tips and tricks
page of the wiki).
// florian

On Friday 15 July 2005 02:40, Craig Hughes wrote:
> Do you have a scope you can use to check if there are signals on the
> lines?
>
> C
>
> On Jul 14, 2005, at 2:49 PM, Sir Graham (Terra) wrote:
> > Hi Craig,
> >
> > We probe in this port and donīt work.  Any idea....
> >
> > First configurate the  port:
> >
> > # stty -F /dev/ttyS2 speed 115200
> >
> > make this comand
> >
> > # yes > /dev/ttyS2
> > Change the cable to the second port and dont work......
> >
> > With the /dev/ttyS0 works well....
> >
> > Is necessary any configuration more? Itīs a extrange problem....
> >
> > Regards.,
> >
> > Sir Graham.
> >
> >
> >
> >
> > ----- Original Message -----
> > From: Craig Hughes
> > To: gumstix-users@lists.sourceforge.net
> > Sent: Thursday, July 14, 2005 11:22 PM
> > Subject: Re: [Gumstix-users] problems second serial port of
> > gumstix....
> >
> >
> > Depends on the waysmall board you have -- most likely it's a STUART
> > waysmall, and then the 2nd port is ttyS2.
> >
> >
> > C
> >
> >
> > On Jul 14, 2005, at 1:33 PM, Sir Graham (Terra) wrote:
> >
> >
> > Hi,
> >
> > We have the gumstix without bluetooth module and without MMC/SD
> > card (This is the gumstix with etherstix).
> >
> > Well, we make a trys with the "second" serial port of Gumstix.
> > What port is this ttyS1, ttyS2, ttyS3?
> >
> > We try in all ports to make this operation:
> >
> > # stty -F /dev/ttyS1 speed 115200
> > # stty -F /dev/ttyS2 speed 115200
> > # stty -F /dev/ttyS3 speed 115200
> >
> > # yes >  /dev/ttyS1    Change the cable to the other conector and
> > nothing....
> > # yes >  /dev/ttyS2    Change the cable to the other conector and
> > nothing....
> > # yes >  /dev/ttyS3    Change the cable to the other conector and
> > nothing....
> >
> > Any idea of the problem?
> >
> > Regards,
> > Sir Graham.


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77&alloc_id492&opclick
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users