Craig, thanks for the update. Is the new version posted yet, if not any estimate as to when it will be posted.   ... just trying to decide whether or not to revert back to the older version.

Brian Sibilsky

 ==============================================================

Re: eth0: link down in Verdex Linux, but not in U-Boot Click to flag this post

by Craig Hughes Jun 06, 2007; 07:45pm :: Rate this Message: (use ratings to moderate[?])

Reply | Reply to Author | Show Only this Message

I found the source of the problem -- I mis-merged some patches while  
trying to get ready to merge the verdex branch back onto the trunk  
(with r1343) -- I'm in the process of trying to fix the merge now;  
ETA tonight sometime.  In the meantime, you can revert to r1342 to  
get a working ethernet and CF -- there might be other broken bits  
too; the mis-merge was in the main gumstix header file in asm-arm/
arch-pxa/gumstix.h which defines all the gumstix GPIOs for the boards  
we sell.  The current version in the HEAD of the verdex branch  
actually has the basix/connex definitions instead of the verdex ones.

C

On Jun 6, 2007, at 5:02 PM, Sibilsky wrote:

> For what its worth I seem to have the same problem with eth0 link  
> down after
> rebuilding the kernel with version 1424. (verdex xlp6)
>
> I also can't mount the CF card, but I'm not sure if that's related.  
> (CF
> cards works in U-boot though)
>
> Brian Sibilsky
>
> -----Original Message-----
> From: gumstix-users-bounces@...
> [mailto:gumstix-users-bounces@...] On Behalf Of  
> Craig
> Hughes
> Sent: Wednesday, June 06, 2007 4:53 PM
> To: General mailing list for gumstix users.
> Subject: Re: [Gumstix-users] eth0: link down in Verdex Linux,but  
> not in
> U-Boot
>
> On Jun 6, 2007, at 2:15 PM, Gert Jim Muller wrote:
>
>> I rebuilt the kernel to add framebuffer support and now the eth0
>> does not come alive any more.
>>
>> The network device works perfectly with U-boot 1.2.0's tftp and the
>> lights are even starting to flash upon an "ifup", but the link
>> stays down and ping and ssh does not work.
>>
>> Any help would be appreciated.
>
> I just noticed the same thing while doing some testing here.  I'm
> working on it as I type.
>
> C
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by DB2 Express
> Download DB2 Express C - the FREE version of DB2 express and take
> control of your XML. No limits. Just data. Click to get it now.
> http://sourceforge.net/powerbar/db2/
> _______________________________________________
> gumstix-users mailing list
> gumstix-users@...
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by DB2 Express
> Download DB2 Express C - the FREE version of DB2 express and take
> control of your XML. No limits. Just data. Click to get it now.
> http://sourceforge.net/powerbar/db2/
> _______________________________________________
> gumstix-users mailing list
> gumstix-users@...
> https://lists.sourceforge.net/lists/listinfo/gumstix-users


-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
gumstix-users mailing list
gumstix-users@...
https://lists.sourceforge.net/lists/listinfo/gumstix-users