Hi Curt;


I did what you and Tuomas suggested. I un-commented the lines.

This is what I got at boot and from “ifconfig –a” :


Configuring network interfaces... eth0: unknown interface: No such device

eth0: unknown interface: No such device

eth0      No such device


SIOCSIFADDR: No such device

eth0: unknown interface: No such device

eth0: unknown interface: No such device

Failed to bring up eth0.



root@omap3-multi:~# ifconfig -a

lo        Link encap:Local Loopback 

          inet addr:  Mask:

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:24 errors:0 dropped:0 overruns:0 frame:0

          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:1728 (1.6 KiB)  TX bytes:1728 (1.6 KiB)


wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:1B:75:8E 

          BROADCAST MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)





"People sleep peaceably in their beds at night only because rough men

stand ready to do violence on their behalf." - George Orwell


From: Curtis Olson [mailto:curtolson@gmail.com]
Sent: Thursday, June 16, 2011 10:59 AM
To: General mailing list for gumstix users.
Subject: Re: [Gumstix-users] Still Have ifconfig problem :(


You've probably checked all the obvious stuff, but in /etc/network/interfaces have you uncommented the "auto eth0" and "iface eth0 inet dhcp" lines?




On Thu, Jun 16, 2011 at 9:46 AM, William Pretty Security Inc wrote:

Hi All;


I double checked that the com board was seated properly and tried a console image I

Built previously with Steve Sakoman’s script …


Still no joy. I get the same error message as before …


I have it in the back of my mind that there was a device driver conflict in the Kernel or something

But darned if I can remember what …




A prisoner of war is a man who tries to kill you and fails, and then asks you not to kill him.

Winston Churchill


EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
gumstix-users mailing list


Curtis Olson:

http://www.atiak.com - http://aem.umn.edu/~uav/

http://www.flightgear.org - http://gallinazo.flightgear.org


No virus found in this message.
Checked by AVG - www.avg.com
Version: 10.0.1382 / Virus Database: 1513/3707 - Release Date: 06/16/11