i just bought two gumstixs (one with Bluetooth (basix 400f-bt) and one connex 400g).
Both boot fine and i see console output via serial port. I have a few questions:
1) The 400f-bt displays at startup:
U-Boot 1.1.2 (Feb 11 2005 - 12:59:06)
*** Warning - bad CRC, using default environment
What does it mean ? How can i correct this ? The 400g doesn't display this.
2) To reduce costs i have not ordered any accessory. Ok, power supply, serial cable was no problem.
But: Bluetooth antenna and USB cable. For Bluetooth antenna i tried to hold a short cable to the antenna pin, and it seems working, but no final solutions. Can anyone tell me the exact name of these connectors ? USB are normal mini USB ? Type A ?
3) I tried out the delivered Etherstix. I connected it to the connex 400g and the waysmall STUART. But it doesn't seem to react. Gumstix requested no IP-address from my router (which has DHCP enabled). I think i even haven't seen any light (10 / 100) at my router. Anything special with it ? Automatically enabled during startup ? Is a Ethernet cross cable needed ?
4) I searched for hcidump in filesystem, but haven't found it. Is it too big ? At least only the raw debugging would be nice to have. Anyone already tried it ? Or is there another way to dump HCI data ?
5) Putting the waysmall together to connex 400g and etherstix seems to be not very stable (mechanically). Has someone a tip how to make it a bit more stable ? Must i put a paper between each f two board, so i get no shortcuts ? 
Regards and sorry for beginner questions,