To supplement the below:
 
I did an lsmod and got the following output:
 
Module                  Size  Used by
mcf25                 202408  0
cfio                    5152  1 mcf25
smc91x                 16100  0
mii                     4768  1 smc91x
gumstix_smc91x          2784  1 smc91x
af_packet              16776  2
g_ether                20476  0
pxa2xx_udc             14244  1 g_ether
gumstix_gadget          1472  1 pxa2xx_udc
proc_gpio               7320  0
gumstix_bluetooth       1440  0
pxa2xx_cs               3076  1
pxa2xx_core            10336  1 pxa2xx_cs
pcmcia                 23848  1 cfio
pcmcia_core            30800  4 mcf25,cfio,pxa2xx_core,pcmcia
firmware_class          8064  1 pcmcia
unix                   22740  12
 
ifconfig gives the following output:
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3785 (3.6 KiB)  TX bytes:3785 (3.6 KiB)
 
usb0      Link encap:Ethernet  HWaddr 42:14:9F:B3:19:21
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
ifconfig eth0 up gives the following:
 
SIOCGIFFLAGS: No such device
 
----- Original Message -----
From: tom neal
To: gumstix-users@lists.sourceforge.net
Sent: Friday, September 29, 2006 8:25 AM
Subject: network not coming up on new netmmc pack

Can anyone lend assistance for the following problem?
 
I just setup a gumstix with the netmmc board.  The network interface does not appear to come up. 
 
I get the following output on the serial console on boot. 
 
Starting network...
udhcpc (v0.9.9-pre) started
Dec 31 16:01:05 udhcpc[196]: udhcpc (v0.9.9-pre) started
pxa2xx_udc: version 4-May-2005
usb0: Ethernet Gadget, version: May Day 2005
usb0: using pxa2xx_udc, OUT ep2out-bulk IN ep1in-bulk STATUS ep6in-bulk
usb0: MAC 42:14:9f:b3:19:21
usb0: HOST MAC 42:14:9f:b3:19:22
usb0: RNDIS ready
Nothing to flush.
NET: Registered protocol family 17
udhcpc (v0.9.9-pre) started
Dec 31 16:01:06 udhcpc[228]: udhcpc (v0.9.9-pre) started
smc91x: not found (-19).
 
I am most concerned about the last line.  Is a driver missing?
 
Tom