Pete,

 

Thanks for the fast response.

The Gumstix-end serial cables are new and from Gumstix.

The PC end is a standard USB/serial cable presenting a DTE/male.

So, unless there’s something strange with the Gumstix cables and they present a DTE interface on a DCE female connector then nothing obviously wrong there. As soon as I’m back at the units I’ll try your suggestion and switch the TX/RX lines.

 

Thanks, Tim.

 


From: Peter Vandrish [mailto:peter.vandrish@gmail.com]
Sent: 24 May 2008 17:54
To: tim.everitt@yr20.com; General mailing list for gumstix users.
Subject: Re: [Gumstix-users] Please be gentle - newbie in tears!

 

Are your serial cables straight through or cross-over? Did you order the serial cable from gumstix?
I would say try switching the tx and rx lines of your serial cable if you have some spare wire lying around.
Pete

On Sat, May 24, 2008 at 1:51 PM, Tim Everitt <tim.everitt@yr20.com> wrote:

Hi,

I've just got a gumstix connex-400xm + console-st and also a verdex-x4m +
console-vx.

I've carefully assembled both systems, all seems well.

I connect a PC (Windows, hyperterm, 115200bps/8N1 no flow control) to the
relevant console ports, apply power to the gumstix systems and... nothing at
all on the serial port.

PC hyperterm and serial port is working ok to other hardware and a loopback
connector.
Power-on LEDs light up on the gumstix boards.
I've tried the other serial ports on each console board.
I've tried a different serial cable.
I've tried different COMport settings at the PC end (e.g. 9600bps).

Same behaviour on both the connex and verdex systems so I assume that there
isn't an isolated hardware fault.

Am I doing something completely dumb?
Does the gumstix smell a Windows PC and refuse to boot?
Please help!

Regards, Tim Everitt.



-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users