Maybe I found a bug with vsfilter 2.39

Anonymous
2011-03-02
2013-05-08

  • Anonymous
    2011-03-02

    when i load an .ass subtitle file ,  the player crashed. I have tried to use windows media player, mpc, kmplayer. all of them crashes. Here is the ass file content:

    [Script Info]
    Original Script: AcFun
    ScriptType: v4.00
    Collisions: Normal
    PlayResX: 540
    PlayResY: 384
    PlayDepth: 32
    Timer: 100.0000
    WrapStyle: 2
    [V4+ Styles]
    Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, TertiaryColour, BackColour, Bold, Italic, Underline, StrikeOut, ScaleX, ScaleY, Spacing, Angle, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, Encoding
    Style: Big, 黑体,36,11861244,11861244,0,-2147483640,-1,0,0,0,100,100,2,0.00,1,1,0,2,30,30,30,1
    [Events]
    Format: Marked, Start, End, Style, Name, MarginL, MarginR, MarginV, Effect, Text
    Dialogue: Marked=0,0:00:00.00,0:00:04.50,Big,AcFun,0000,0000,0000,,{\a5\pos(140, 60)\fade(255,0,255,0,0,0,4500)\c&H00BBCC\fs50}{\frz-40}{\fry-30}祈り宿な    祈り宿な\nがら生ま    がら生ま\nれてきた    れてきた\n    祈り宿な    祈り宿な\n    がら生ま    がら生ま\n    れてきた    れてきた
    Dialogue: Marked=0,0:00:00.30,0:00:04.80,Big,AcFun,0000,0000,0000,,{\a5\pos(150, 50)\fade(255,0,255,0,0,0,4500)\c&H00C9D6\fs50}{\frz-45}{\fry-35}祈り宿な    祈り宿な\nがら生ま    がら生ま\nれてきた    れてきた\n    祈り宿な    祈り宿な\n    がら生ま    がら生ま\n    れてきた    れてきた
    Dialogue: Marked=0,0:00:01.59,0:00:06.09,Big,AcFun,0000,0000,0000,,{\a5\pos(160, 40)\fade(255,0,255,0,0,0,4500)\c&H00D6E0\fs50}{\frz-50}{\fry-40}祈り宿な    祈り宿な\nがら生ま    がら生ま\nれてきた    れてきた\n    祈り宿な    祈り宿な\n    がら生ま    がら生ま\n    れてきた    れてきた
    Dialogue: Marked=0,0:00:01.90,0:00:06.40,Big,AcFun,0000,0000,0000,,{\a5\pos(170, 30)\fade(255,0,255,0,0,0,4500)\c&H00E4EA\fs50}{\frz-55}{\fry-45}祈り宿な    祈り宿な\nがら生ま    がら生ま\nれてきた    れてきた\n    祈り宿な    祈り宿な\n    がら生ま    がら生ま\n    れてきた    れてきた
    
     
  • BrunoJ
    BrunoJ
    2011-03-02

    Sorry, but I just can't resist a straight line like that….  Maybe the file should be wiped.  :)

     
  • Liisachan
    Liisachan
    2011-05-15

    Your script says "ScriptType: v4.00" and it has "Marked=0", meaning it's SSA.
    Yet you have  from  ASS (a different format). Obviously this doesn't seem to work.