MPC responds to volume up, down, mute keys

Freedeanna
2012-10-26
2013-05-08
  • Freedeanna
    Freedeanna
    2012-10-26

    Hi, I notice that mpc responds to the function keys that my keyboard uses for volume control, which normally alters the windows master volume. It would be great if I could stop this behaviour somehow. I have to unfocus mpc in order to get back the control of the windows volume. I came here and did a search and found it was an old issue, with at least two unanswered threads about it, eg. bakedatom's question here.

    I don't know if there is a solution or if it has been fixed/added as an option. I checked the hotkeys, but I don't see a way to do it there, as there seems no mention of the - presumably standard - keyboard events and their effect. I'm left thinking I'm going to have to write something in AutoHotkey to intercept them when MPC is in focus. It seems an odd failing in what is otherwise an awesome piece of software.

    Apologies if this is the wrong place to post - I'm new and sourceforge seems a bit crazy yet. ;)

     
  • Ray
    Ray
    2013-01-23

    Under Player-> Options -> Keys-> Commands - Just remove the App Command fields for these 3 commands and now only the WIndows master volume will change