Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Disconnected straight away

Help
adamjseed
2013-09-30
2013-10-02
  • adamjseed
    adamjseed
    2013-09-30

    Hi all,

    I have a fresh install of guacamole on ubuntu 12.04 server and added a connection to a windows server 2008 RDP on ip 10.10.10.113

    When I log into guacamole it shows a red 'no access' sign and Disconnected.

    Here is my config and log files

    cat /var/log/tomcat6/catalina.2013-10-01.log

    Oct 1, 2013 2:31:02 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
    WARNING: Problem with directory [/usr/share/tomcat6/server/classes], exists: [false], isDirectory: [false], canRead: [false]
    Oct 1, 2013 2:31:02 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
    WARNING: Problem with directory [/usr/share/tomcat6/server], exists: [false], isDirectory: [false], canRead: [false]
    Oct 1, 2013 2:31:02 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
    WARNING: Problem with directory [/usr/share/tomcat6/shared/classes], exists: [false], isDirectory: [false], canRead: [false]
    Oct 1, 2013 2:31:02 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
    WARNING: Problem with directory [/usr/share/tomcat6/shared], exists: [false], isDirectory: [false], canRead: [false]
    Oct 1, 2013 2:31:03 AM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8080
    Oct 1, 2013 2:31:03 AM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 354 ms
    Oct 1, 2013 2:31:03 AM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Oct 1, 2013 2:31:03 AM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
    Oct 1, 2013 2:31:03 AM org.apache.catalina.startup.HostConfig deployDescriptor
    INFO: Deploying configuration descriptor ROOT.xml
    Oct 1, 2013 2:31:03 AM org.apache.catalina.startup.HostConfig deployDescriptor
    INFO: Deploying configuration descriptor guacamole.xml
    Oct 1, 2013 2:31:03 AM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-8080
    Oct 1, 2013 2:31:03 AM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 228 ms
    Oct 1, 2013 2:31:09 AM org.slf4j.impl.JCLLoggerAdapter info
    INFO: User mapping file /etc/guacamole/user-mapping.xml has been modified.
    Oct 1, 2013 2:31:09 AM org.slf4j.impl.JCLLoggerAdapter info
    INFO: Reading user mapping file: /etc/guacamole/user-mapping.xml
    Oct 1, 2013 2:31:09 AM org.slf4j.impl.JCLLoggerAdapter info
    INFO: Successful login from 10.10.10.104 for user "adam".
    Oct 1, 2013 2:31:09 AM org.slf4j.impl.JCLLoggerAdapter info
    INFO: Connection from 10.10.10.104 succeeded.
    

    cat /etc/guacamole/user-mapping.xml

    <user-mapping>
        <!-- Example user configurations are given below. For more information,
             see the user-mapping.xml section of the Guacamole configuration
             documentation: http://guac-dev.org/Configuring%20Guacamole -->
        <!-- Per-user authentication and config information -->
    <authorize username="adam" password="adam">
        <protocol>rdp</protocol>
        <param name="hostname">10.10.10.113</param>
        <param name="port">3389</param>
    </authorize>
    </user-mapping>
    

    I'm at a bit of a loss on how to debug this, so any help would be welcomed.

     
    Last edit: adamjseed 2013-10-01
  • adamjseed
    adamjseed
    2013-10-01

    ok, so I feel a bit stupid, I didn't install the server and client on the machine. After running the configure script and getting everything to say yes I have a different login page, 0.8.3. I can log in fine but when I click on the default connect I just get a black screen.

    Any suggestions?

     
  • adamjseed
    adamjseed
    2013-10-02

    It finally started work, Here are my install notes for ubuntu 12.04:

    get downloads and extract
    wget http://sourceforge.net/projects/guacamole/files/current/source/guacamole-server-0.8.3.tar.gz/download -O guacamole-server-0.8.3.tar.gz
    wget http://sourceforge.net/projects/guacamole/files/current/source/guacamole-client-0.8.3.tar.gz/download -O guacamole-client-0.8.3.tar.gz
    tar -xzf guacamole-server-0.8.3.tar.gz
    tar -xzf ~/guacamole-client-0.8.3.tar.gz

    Install missing packages
    apt-get install gcc libpng12-dev libcairo2-dev libvncserver-dev libfreerdp-dev libvorbis-dev libssh-dev libpango1.0-dev libpulse-dev openjdk-7-jdk

    Install Server
    cd ~/guacamole-server-0.8.3/
    ./configure --with-init-dir=/etc/init.d
    make
    make install

    Install Client
    apt-get install maven
    cd ~/guacamole-client-0.8.3/
    mvn package
    cp guacamole/target/guacamole-0.8.3.war /var/lib/tomcat6/webapps/guacamole.war
    mkdir /usr/share/tomcat6/.guacamole
    ln -s /etc/guacamole/guacamole.properties /usr/share/tomcat6/.guacamole/

    Do a reboot and it all started working.