Problem installing under OSX

2009-02-02
2013-05-28
  • Hi when trying to install TiEmu 2.00 i get the following error.

    I have updated my fink, and im using FinkCommander.

    Im verry much newb to all this unix stuff.

    Allso if i dont use fink and just tries using the install.command then when i enter my password for sudo, nothing really happens.

    Really hope someone can help. Would love to have the TI89 on my mac so i dont have to emulate it, or cary it with me every day.

    make
    make  all-recursive
    Making all in build
    make[2]: Nothing to be done for `all'.
    Making all in intl
    make[2]: Nothing to be done for `all'.
    Making all in po
    test -z "fr.gmo" || make fr.gmo
    : --update fr.po libticables.pot
    rm -f fr.gmo && : -c --statistics -o fr.gmo fr.po
    mv: rename t-fr.gmo to fr.gmo: No such file or directory
    make[3]: *** [fr.gmo] Error 1
    make[2]: *** [stamp-po] Error 2
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2
    ### execution of make failed, exit code 2
    Removing runtime build-lock...
    Removing build-lock package...
    /sw/bin/dpkg-lockwait -r fink-buildlock-libticables3-3.9.5.1-1
    (Reading database ... 4119 files and directories currently installed.)
    Removing fink-buildlock-libticables3-3.9.5.1-1 ...
    Failed: phase compiling: libticables3-3.9.5.1-1 failed

    Before reporting any errors, please run "fink selfupdate" and
    try again.  If you continue to have issues, please check to see if the
    FAQ on fink's website solves the problem.  If not, ask on the fink-users
    or fink-beginners mailing lists, with a carbon copy to the maintainer:

     
    • What version of Mac OS X are you using? Unless it's 10.3, I'm sorry, the only suggestion I can give you is "don't bother".

      If you excuse me for not even tailoring it to your specific situation, here is my canned response to people who e-mail me about the TiEmu 2.00 Fink packages:

      You're not the first one to report this problem. Unfortunately I can't be of much help in this without doing any further research. I haven't touched TiEmu for three years and I have no idea how my Fink packages from then perform with today's Fink. Also, those packages were made for the 10.3 distribution of Fink, I've never tried them on 10.4 or 10.5. TiEmu itself has progressed in that time as well, and I've never tried to make newer versions work on Mac OS X again. I also don't know how well TiEmu 2.00 works on Intel Macs as the Mac-specific stuff in the configure scripts etc. was written in the times of PPC-only Macs, but I hear there is some progress on that front in newer versions.

      I currently have neither time nor interest for working on TiEmu, so I'm afraid you're on your own. It's possible that you'd have more success with a current version of TiEmu than with my old Fink packages. Maybe there's someone who can help you on the tiemu mailing lists <http://lpg.ticalc.org/prj_tiemu/mailing_list.html>.

      Sorry to be unhelpful

      -Christian

       
    • Ok good to know :)