no thumbnails

2007-11-02
2013-04-04
  • Jack Bowling
    Jack Bowling
    2007-11-02

    I must be doing something wrong. I have all required dependencies installed on both my i386 laptop and my AMD64 desktop and I can get no thumbnail generation from my Pentax PEF files on g-r-g 0.5.1 or the earlier version. Maybe somebody can steer me toward salvation. I'm running Ubuntu Gutsy.

    Jack

     
    • Daniele Isca
      Daniele Isca
      2007-11-02

      Please,look for your model in the cameras supported list on Dcraw home page. If supported, run gtkrawgallery.py from a shell and report your error. Bye!

       
    • Jack Bowling
      Jack Bowling
      2007-11-03

      Yes, the Pentax K10D is listed as supported. I run other raw photo apps which rely on dcraw such as UFRAW and it has no problems. Here is what I get when I try to load images in gtkrawgallery:

      $ python gtkrawgallery.py
      /home/jb/Pictures/20070609/PEFs/beaver_pond1_mt_robson_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO1_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO2_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO3_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO4_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO5_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO6_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO7_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image
      /home/jb/Pictures/20070609/PEFs/CAGO8_Portal_Lk_20070609.PEF has no thumbnail.
      error loading image

      - installed apps/libraries

      $ dcraw

      Raw Photo Decoder "dcraw" v8.39
      by Dave Coffin, dcoffin a cybercom o net

      Usage:  dcraw [options] file1 file2 ...

      $ python -V
      Python 2.5.1

      $ dpkg -l python-gtk2
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
      |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
      ||/ Name           Version        Description
      +++-==============-==============-============================================
      ii  python-gtk2    2.12.0-0ubuntu Python bindings for the GTK+ widget set

      $ dpkg -l libgtk*
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
      |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
      ||/ Name           Version        Description
      +++-==============-==============-============================================
      un  libgtk1.3-comm <none>         (no description available)
      un  libgtk1.3-dev  <none>         (no description available)
      ii  libgtk2-ex-pod 0.17-0ubuntu2  Perl Gtk2 widget for displaying Plain Old Do
      ii  libgtk2-ex-sim 0.50-1         A simple interface to Gtk2's complex MVC lis
      ii  libgtk2-perl   1:1.140-1build Perl interface to the 2.x series of the Gimp
      un  libgtk2-perl-d <none>         (no description available)
      un  libgtk2-podvie <none>         (no description available)
      ii  libgtk2.0-0    2.12.0-1ubuntu The GTK+ graphical user interface library
      un  libgtk2.0-0png <none>         (no description available)
      ii  libgtk2.0-bin  2.12.0-1ubuntu The programs for the GTK+ graphical user int
      ii  libgtk2.0-cil  2.10.2-1ubuntu CLI binding for the GTK+ toolkit 2.10
      ii  libgtk2.0-comm 2.12.0-1ubuntu Common files for the GTK+ graphical user int
      un  libgtk2.0-data <none>         (no description available)
      ii  libgtk2.0-dev  2.12.0-1ubuntu Development files for the GTK+ library
      un  libgtk2.0-doc  <none>         (no description available)
      ii  libgtkhtml2-0  2.11.1-0ubuntu HTML rendering/editing library - runtime fil
      ii  libgtkhtml2.0- 2.16.0-7ubuntu CLI binding for GtkHTML 3.8
      ii  libgtkhtml3.14 3.16.1-0ubuntu HTML rendering/editing library - runtime fil
      un  libgtkhtml3.14 <none>         (no description available)
      ii  libgtkhtml3.8- 1:3.13.5-1     HTML rendering/editing library - runtime fil
      un  libgtkhtml3.8- <none>         (no description available)
      un  libgtkmm-2.4-1 <none>         (no description available)
      un  libgtkmm-2.4-1 <none>         (no description available)
      ii  libgtkmm-2.4-1 1:2.12.0-0ubun C++ wrappers for GTK+ 2.4 (shared libraries)
      un  libgtksourcevi <none>         (no description available)
      ii  libgtksourcevi 1.8.5-1        common files for the GTK+ syntax highlightin
      ii  libgtksourcevi 1.8.5-1        shared libraries for the GTK+ syntax highlig
      ii  libgtksourcevi 2.0.1-0ubuntu1 shared libraries for the GTK+ syntax highlig
      ii  libgtksourcevi 2.0.1-0ubuntu1 common files for the GTK+ syntax highlightin
      ii  libgtkspell0   2.0.10-3build1 a spell-checking addon for GTK's TextView wi

      $  dpkg -l libimage-exiftool-perl
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
      |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
      ||/ Name           Version        Description
      +++-==============-==============-============================================
      ii  libimage-exift 6.90-1         Library and program to read and write meta i

      $  dpkg -l libglade*
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
      |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
      ||/ Name           Version        Description
      +++-==============-==============-============================================
      ii  libglade2-0    1:2.6.2-1      library to load .glade files at runtime
      ii  libglade2.0-ci 2.10.2-1ubuntu CLI binding for the Glade libraries 2.6

      $  dpkg -l python-imaging*
      Desired=Unknown/Install/Remove/Purge/Hold
      | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
      |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
      ||/ Name           Version        Description
      +++-==============-==============-============================================
      ii  python-imaging 1.1.6-1        Python Imaging Library

      =====================================

      The only requirement not met is for exiftool >= 6.92

      Jack

       
    • Daniele Isca
      Daniele Isca
      2007-11-03

      I have successfully opened several PEF and DNG files. Install latest version of Dcraw and look for disabled embedded thumbnails on your camera settings.