Javier Kohen wrote:
> Track_get_item was getting called way too often. The internal switch
> case was relatively convenient, but inefficient. I don't think the
> code is any harder to read. On the contrary, it is closer to the other
> cases of the switch, and it's more explicit what's going on.
> I'd suggest using the "property" pattern (i.e. a dictionary) in the
> future instead of named fields for this particular use case where
> things are always accessed by some key and the logic rarely (if ever)
> needs to reference them by field name.
> This is the fifth patch and all for tonight. I hope it all gets to the
> mailing list.
I've committed this one to SVN as well. Thanks again for your input!