On Sat, Oct 6, 2012 at 6:06 PM, Jonathan Neuschäfer <j.neuschaefer@gmx.net> wrote:
On Sat, Oct 06, 2012 at 10:22:29AM +0200, Javier Kohen wrote:
> Actually they made it to the list :-) I have commit rights and they look
> good to me, but I'd rather wait for someone who's worked more closely with
> the distros to take a look, to make sure we're not locking users out from
> gktpod (I would think not, except for very old distros... but I don't have
> much practical experience with them).

The only patch that should cause any trouble is the one that replaces
g_mapped_file_free by g_mapped_file_unref (introduced in glib 2.22).
I suggest adding something like the following somewhere in the libgpod
source (glib-compat.h, maybe):

        #if GLIB_VERSION_CHECK(2,22,0) == 0
        #define g_mapped_file_unref(f) g_mapped_file_free(f)

I've pushed the rest of the patchset as "dev2" on github.

I've pull all your changes and pushed them, as libgpod doesn't compile with glib 2.22+ without this patch (all warnings cause compilation errors). Instead of the fix you suggested I'm using AC_CHECK_FUNCS.

Thank you!

[ BTW, gtkpod requires GLib 2.28. ]

Jonathan Neuschäfer