"." <peace@AleksandrSolzhenitsyn.net> wrote:


On 12/02/2011 11:19 AM, phantomjinx wrote:
"." <peace@AleksandrSolzhenitsyn.net> wrote:


On 12/02/2011 01:06 AM, jean-baptiste bertin wrote:
Don't give up just yet, looks like you're getting somewhere. 10.04 appears to have an "anjuta" package:

Try and install it. And anjuta-dev as the next step if this still fails

I just installed "anjuta" and anjuta-dev"

Here's the new error message;

configure: error: *** No package 'libgpod-1.0' found


No idea where or how to get libgpod-1.0 

Looked for it on the web but there's a lot of confusing stuff.

Thanks, everyone.






On 2 December 2011 01:36, . <peace@aleksandrsolzhenitsyn.net> wrote:


On 12/01/2011 03:25 PM, phantomjinx wrote:
"." <peace@AleksandrSolzhenitsyn.net> wrote:


On 12/01/2011 01:35 PM, phantomjinx wrote:
"." <peace@AleksandrSolzhenitsyn.net> wrote:


On 12/01/2011 10:14 AM, phantomjinx wrote:
> "." <peace@AleksandrSolzhenitsyn.net> wrote:
>
>

I'm running Ubuntu 10.04 and for the life of me I can't figure out how
to install GtkPod 2.1.0!

For that matter I can NEVER figure out how to install any linux software
using the ./configure.....make....make install stuff.

I have GtkPod 0.99.14 installed.  Can the newer versions be installed on
Ubuntu 10.04?
>
>
> -------------------------
>
> All the data continuously generated in your IT infrastructure
> contains a definitive record of customers, application performance,
> security threats, fraudulent activity, and more. Splunk takes this
> data and makes sense of it. IT sense. And common sense.
> http://p.sf.net/sfu/splunk-novd2d
> -------------------------
>
> Gtkpod-questions mailing list
> Gtkpod-questions@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gtkpod-questions
>
>
> 10.04 is gtk 2 while gtkpod 2.1.0 is gtk3. The last gtk2 version is 2.0.1 so you should try that version. The latest ubuntu is gtk3.
>
> configure logs and reports unsatisfied dependencies so if still having problems try posting its output to pastebin.
>
> Regards
>
> Phantomjinx
> --
> Sent from my Android phone with K-9 Mail. Please excuse my brevity.



First I downloaded 2.0.1

Here are the results of my unsuccessful attempt to install GtkPod 2.0.1


http://pastebin.com/peBs7Weg



>
>
> ------------------------------------------------------------------------------
> All the data continuously generated in your IT infrastructure
> contains a definitive record of customers, application performance,
> security threats, fraudulent activity, and more. Splunk takes this
> data and makes sense of it. IT sense. And common sense.
> http://p.sf.net/sfu/splunk-novd2d
>
>
> _______________________________________________
> Gtkpod-questions mailing list
> Gtkpod-questions@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gtkpod-questions


By the looks of it you haven't heeded any reported errors.

1. You tried to clone libgpod and it failed due to an already existing dir. Presumably the existing dir was up to date?

2. Configure for libgpod failed due to failed dependency of libplist. So running make is pointless and will give uncertain results.

3. Moving onto gtkpod's configure is not going to magically work. Surprisingly it is looking for libgpod and fails to find it. Running make is pointless.

So....

Before running make always ensure configure completed successfully, ie. No errors. There may be warnings but not errors. The last things configure does is generate make files. This is a good indicator that things are going correctly.

Getting configure to complete requires installing dev packages and running until success. For example find libplist-dev in the repos, install and rerun.

You are trying to compile libgpod. To get gtkpod 2 working only requires the release version of libgpod, which should be in ubuntus repos.

If you do compile and install libgpod then you need to set the PKG_CONFIG_PATH variable. Google should explain how.

Hope that helps.

Phantomjinx


--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.


Tried to find or get libgpod-1.0 but Ubuntu 10.04 says the latest version is 8.X.X

See the error message during ./confgure below.


configure:12012: error: *** No package 'libgpod-1.0' found


Thanks for the help.  I'm going to quit.  This stuff is beyond me.  All I really want to do is get the iPod playlists as displayed in GtkPod in alphabetic order.







That may be true but the word 'package' is confusing you.

There exists a directory for the configuring of libraries under /usr/lib/pkgconfig. When libgpod dev is installed it will locate a file in the dir called libgpod-1.0. The configure script is looking for this file. This file is part of the libgpod 8.x.x ubuntu package, where the 8.x.x is the release version of the code while the 1.0 is the so number of the library.

So install the ubuntu package of libgpod and go from there.

PGR
--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Well, thanks for the help again.  On the new effort at installation GtkPod the current error message is;


configure: error: *** No package 'libanjuta-1.0' found

I have no idea where to get "libanjuta-1.0"....it's not in Synaptic.

Any ideas?



------------------------------------------------------------------------------
All the data continuously generated in your IT infrastructure
contains a definitive record of customers, application performance,
security threats, fraudulent activity, and more. Splunk takes this
data and makes sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-novd2d
_______________________________________________
Gtkpod-questions mailing list
Gtkpod-questions@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gtkpod-questions



Lucid should have some version of libgpod-dev in its repo. It may be less than libgpod 1.0 so you'll have to compile it yourself. Considered upgrading lucid to maverick or natty?

PGR
--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.


I've considered Maverick & Natty but fear that I'll ruin my entire system and that I'll have to fix a lot of programs that get wrecked during the upgrade.  I'm famous for that.

What's your opinion?  I like the LTS of 10.04.




------------------------------------------------------------------------------
All the data continuously generated in your IT infrastructure 
contains a definitive record of customers, application performance, 
security threats, fraudulent activity, and more. Splunk takes this 
data and makes sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-novd2d


_______________________________________________
Gtkpod-questions mailing list
Gtkpod-questions@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gtkpod-questions
My position is slightly different.

Due to developing and providing unstable builds I need to keep up to date with the latest changes, eg. Gtk2 to gtk3.

Personally though I tend to update to the previous version to the latest release since they are fairly up to date and had bugs squashed. Leaving updating too long I find that taking advantage of new updates becomes increasingly problematic.

No hard and fast rule.

PGR
--
Sent from my Android phone with K-9 Mail. Please excuse my brevity.