thank you Andy for the response,  yes the install process begins to work, but at the end near the final , it stops with error:
[[Linking C:\DOCUME~1\eros\LOCALS~1\Temp\gtkglext-0.11.11652\gtkglext-0.11.1\dis
t\setup\setup.exe ...
Configuring gtkglext-0.11.1...
setup.exe: The pkg-config package gtkglext-1.0 version >=1.0.5 is required but
it could not be found.
cabal: Error: some packages failed to install:
gtkglext-0.11.1 failed during the configure step. The exception was:
ExitFailure 1  ]]
 
i don't know it is asking for gtkglext-1.0.5 while the available is version gtkglext-0.11.1
i have tried also  "cabal install opengl gtk gtkglext --reinstall"  without success.
thanks
 
> To: gtk2hs-devel@lists.sourceforge.net
> From: lazycat.manatee@gmail.com
> Date: Thu, 19 Aug 2010 21:53:11 +0800
> Subject: Re: [Gtk2hs-devel] gtk and opengl
>
> eros olmi <erosolmiz@hotmail.com> writes:
>
> > hello
> > i have installed gtk for Haskell Platform 2010.2 on windows xp, it is working okay, now i want to
> > use gtk with opengl , it
> > is said that i must install gtk2hs with --enable-opengl flag, but how to do that for ms windows ?
> > "cabal install gtk
> > --enable-opengl" are not acceptable. at the beginning i have installed gtk using "cabal install
> > gtk". any help appreciated
> > regards
> You just need do
> "cabal instal opengl gtk gtkglext",
> then you can find OpenGL demo at http://code.haskell.org/gtkglext/demo/RotatingCube.hs
>
> Cheers,
>
> -- Andy
>
>
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by
>
> Make an app they can't live without
> Enter the BlackBerry Developer Challenge
> http://p.sf.net/sfu/RIM-dev2dev
> _______________________________________________
> Gtk2hs-devel mailing list
> Gtk2hs-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gtk2hs-devel