Hi everyone,
 
I installed and tested gtk2hs successfully on a Windows 7 machine. Where I'm stucking is the glade/libglade thing.
I took the version from http://ftp.gnome.org/pub/GNOME/binaries/win32/glade3/3.6/glade3-3.6.7-with-GTK+.exe
And it is installed in D:\prgs\Gtk+
But when running the cabal-configure step it halts with the oh so familiar:
 
C:\Users\Administrator>cabal install glade --extra-lib-dirs=D:\prgs\Gtk+\lib --extra-include-dirs=D:\prgs\Gtk+\include
 
Linking C:\Users\ADMINI~1\AppData\Local\Temp\glade-0.12.03828\glade-0.12.0\dist\
setup\setup.exe ...
Configuring glade-0.12.0...
setup.exe: Missing dependencies on foreign libraries:
* Missing C libraries: glade-2.0, gtk-win32-2.0, xml2, gdk-win32-2.0, atk-1.0,
gio-2.0, gdk_pixbuf-2.0, pangowin32-1.0, gdi32, pangocairo-1.0, pango-1.0,
cairo, gobject-2.0, gmodule-2.0, glib-2.0, intl
This problem can usually be solved by installing the system packages that
provide these libraries (you may need the "-dev" versions). If the libraries
are already installed but in a non-standard location then you can use the
flags --extra-include-dirs= and --extra-lib-dirs= to specify where they are.
cabal: Error: some packages failed to install:
glade-0.12.0 failed during the configure step. The exception was:
ExitFailure 1
 
And my pkg-config output:
C:\Users\Administrator>pkg-config --cflags --libs gtk+-2.0 libglade-2.0
-mms-bitfields Files/Haskell Platform/2011.2.0.0/mingw/include/libxml2 -ID:/prgs
/Gtk+/include/gtk-2.0 -ID:/prgs/Gtk+/lib/gtk-2.0/include -ID:/prgs/Gtk+/include/
atk-1.0 -ID:/prgs/Gtk+/include/cairo -ID:/prgs/Gtk+/include/pango-1.0 -ID:/prgs/
Gtk+/include/glib-2.0 -ID:/prgs/Gtk+/lib/glib-2.0/include -ID:/prgs/Gtk+/include
/libpng12 -ID:/prgs/Gtk+/include/libglade-2.0 -ID:/Program  Files/Haskell Platfo
rm/2011.2.0.0/mingw/lib -LD:/prgs/Gtk+/lib -LD:/Program -lglade-2.0 -lgtk-win32-
2.0 -lxml2 -lgdk-win32-2.0 -latk-1.0 -lgio-2.0 -lgdk_pixbuf-2.0 -lpangowin32-1.0
 -lgdi32 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib
-2.0 -lintl