Not working on OSX anymore

Help
2009-11-09
2012-12-26
  • Evan Raskob
    Evan Raskob
    2009-11-09

    Hi,

    I can't get this version working on 10.5.8 - I installed the GStreamer-MacBuild-0.10.2-Leopard.dmg but get these error when I try to run an example sketch (Loop.pde):

    (GSVideo:215): GStreamer-WARNING **: Failed to load plugin '/opt/local/lib/gstreamer-0.10/libgstadpcmdec.so': dlopen(/opt/local/lib/gstreamer-0.10/libgstadpcmdec.so, 2): Library not loaded: /opt/local/lib/libgstbase-0.10.0.dylib
      Referenced from: /opt/local/lib/gstreamer-0.10/libgstadpcmdec.so
      Reason: Incompatible library version: libgstadpcmdec.so requires version 23.0.0 or later, but libgstbase-0.10.0.dylib provides version 20.0.0

    … (repeated for all plugins)

    It looks like a version conflict with my MacPorts installation.  I updated all the gst libraries, but no luck.  I also tried removing the MacBuild (and lines from launchctrl.conf) and manually linking the gstreamer libs to the proper directories, but started getting odd "symbol not found" errors in sqlite3 and glib that I couldn't track down.  Any ideas??

     
  • Andres Colubri
    Andres Colubri
    2009-11-09

    I haven't experienced problems with the 0.10.2-Leopard installer…

    Maybe the lines the installer adds to /etc/launch.conf are causing some trouble on your system?