Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1568 mbroot 'INBOX' is reset to empty every login

v4.x
closed
nobody
5
2013-06-18
2013-01-13
mmueller
No

In my GroupOffice installation I've got several mailaccounts using the same external mailserver. Most of these accounts are autocreated by imapauth module during the first login of the correlating user. Some are manually created as additional mailaccounts. For every account mbroot is set to 'INBOX' (even in imapauth.config.php the parameter 'mbroot' => 'INBOX').
The manually created accounts work like a charm and all folders are shown in correct structure. Mbroot stays 'INBOX'.
For the autocreated accounts the parameter mbroot is cleared everytime the assigned user logs in. No matter if mbroot is set to 'INBOX' manually in GroupOffice, directly in database or not. The affected accounts work in mail module indeed, but all folders are shown as subfolders of INBOX.

Discussion

  • Could you send me an IMAP test account?

     
    • status: open --> pending
     
  • mmueller
    mmueller
    2013-01-24

    I sent you a test account to mschering@users.sf.net. Thx.

     
    Last edit: mmueller 2013-01-24
  • Can you check if this is fixed now?

     
  • mmueller
    mmueller
    2013-05-03

    Great. Now it works. Tried it with Version 4.1.57. I still had to delete the automatically created mailbox seetings in email module. After a new login, all folders are shown in correct structure.

     
    • status: pending --> closed