Hi Roger,

Thanks for your help!

Finally I've been able to solve it by using the rpc.rigd daemon instead of rigctld.

Within Grig I now use model number 1901 (RPC rig) instead of 2 (NET rigctl) and it looks like everything is working now! :-).

Regards,
Javier



El 25 de octubre de 2011 15:56, <roger@efn.org> escribió:
Have you gotten an answer yet?

I've never worked with the software, but if you can't get the one to work,
is the default firewall on Ubuntu blocking it?
to test, login to the command line and run:
sudo  /etc/init.d/iptables stop
enter your password and iptables (the firewall), should stop.  Try it at
that point.
(not sure if you tried something similar, also, don't know the ports
involved)

I did see this thread:
http://lists.gnu.org/archive/html/tlf-devel/2008-01/msg00009.html



> Hi everyone!
>
> We are trying to setup a radio server, which is hooked up to a Kenwood
> TS-2000 rig, so that it can be accesible over the LAN by other computers
> running Grig. This is what we have been trying:
>
> 1) We have a server running ubuntu 10.04 LTS with Grig 0.7.2 installed.
> This
> computer is hooked up to a Kenwood TS-200 rig by means of a serial
> connection under /dev/ttyS2.
> 2) If we execute the command "rigctl -m 214 -r /dev/ttyS2 -s 9600" we are
> able to correctly communicate with the Kenwood TS-2000 rig.
> 3) As we need to use this radio remotely, we have added to our
> /etc/rc.local
> file the following command, so that the remote daemon starts after the
> server boots up: "/usr/bin/rigctld -m 214 -r /dev/ttyS2 -s 9600 &"
> 4) After the computer boots the daemon starts running and if we execute
> the
> command "rigctl -m 2 -r localhost" we are able to correctly communicate
> with
> the Kenwood TS-200 rig.
> 5) At this point we can also use the command "grig -m 2 -r localhost" and
> Grig works correctly with our rig.
>
> The problem comes now when we try to connect from another computer (in the
> same LAN) to the previous server, who's IP address is 10.13.30.141.
>
> 1) If we execute the command "rigctl -m 2 -r 10.13.30.141" from any other
> computer we are able to correctly connect to the server and send commands
> the rig.
> 2) If we execute the command "grig -m 2 -r 10.13.30.141" from any other
> computer we obtain the following:
>
> 2011/10/23 13:32:55;;GRIG;;4;;grig_debug_init: Debug handler initialised.
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig:rig_init called
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig: loading backend dummy
> 2011/10/23 13:32:55;;HAMLIB;;4;;dummy: _init called
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig_register (1)
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig_register (2)
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig:rig_open called
> 2011/10/23 13:32:55;;HAMLIB;;4;;netrigctl_open called
> 2011/10/23 13:32:55;;GRIG;;2;;rig_daemon_start: Failed to open rig port
> 10.13.30.141 (permissions?)
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig:rig_cleanup called
> 2011/10/23 13:32:55;;HAMLIB;;4;;rig:rig_close called
> 2011/10/23 13:32:55;;HAMLIB;;4;;netrigctl_close called
>
> We don't understand why, when attempting to connect to the server from any
> other computer, rigctl works but Grig doesn't, bearing in mind that we use
> the same input arguments for both programs. Is there any additional
> configuration needed in order to use Grig with a remote radio over the
> network?
>
> We would be very grateful if someone could help us out with this issue!
>
> Thank you very much in advance,
> Javier
> ------------------------------------------------------------------------------
> The demand for IT networking professionals continues to grow, and the
> demand for specialized networking skills is growing even more rapidly.
> Take a complimentary Learning@Cisco Self-Assessment and learn
> about Cisco certifications, training, and career opportunities.
> http://p.sf.net/sfu/cisco-dev2dev_______________________________________________
> Groundstation-user mailing list
> Groundstation-user@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/groundstation-user
>