No package 'gtk+-2.0' found

Help
2007-06-09
2013-03-18
  • Hi:

    I am trying to install gpredict-8.0.0 on OpenSuse 10.2.

    Fixed a couple of other dependencies on my own but have been stumped by this latest one.  I've installed a few gtk dev libraries with no luck.  I don't want to go too crazy installing libs willy nilly.  Below are the last few lines from the console.  Anyone have any thoughts?

    Thanks.

    Steve.

    checking pkg-config is at least version 0.9.0... yes
    checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.8.0 glib-2.0 >= 2.10.0 gthread-2.0 >= 2.10.0) were not met:

    No package 'gtk+-2.0' found
    No package 'glib-2.0' found
    No package 'gthread-2.0' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables PACKAGE_CFLAGS
    and PACKAGE_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

     
    • Steve,

      You have probably installed version 1.x of gtk+ - you need version 2.8 or later.
      On OpenSuse 10.2 you will need the following packages and their respective dependencies, if any:

      glib2
      glib2-devel
      gtk2
      gtk2-devel
      curl
      curl-devel

      curl is optional but necessary for network support (i.e. update of TLE from network)
      All the above packages are available on the OpenSuse DVD, see
      http://www.novell.com/products/linuxpackages/opensuse/index_all.html

      I hope this helps you.

      Alex

       
    • Alex.

      I had some of those but somehow missed the devel parts.  Nice to have a concise list to work from.

      SUMMARY:

      gpredict version... : 0.8.0
      Glib version....... : 2.12.4
      Gthread version.... : 2.12.4
      Gdk version........ : 2.10.6
      Gtk+ version....... : 2.10.6
      Curl version....... : 7.15.5
      Enable coverage.... : no

      Seems to work great now.  Even already had my hometown in the list of groundstations.

      Thanks for the quick reply for support.

      Steve.