I was having trouble getting this installed. But, i've got it just want to let everybody know what i had to do.
I know that i am using an outdated feisty install that aside i was still going to find a way to get this up and going.

First up i had to update my apt repos
$sudo vi /etc/apt/sources.list
change these lines to (and the others):
>deb http://old-releases.ubuntu.com/ubuntu/ feisty main restricted
>deb-src http://old-releases.ubuntu.com/ubuntu/ feisty main restricted
>deb http://old-releases.ubuntu.com/ubuntu/ feisty-updates main restricted
>deb-src http://old-releases.ubuntu.com/ubuntu/ feisty-updates main restricted
$sudo apt-get update

Second we need to install the libsvn pkg
$sudo apt-get install libsvn-dev

make sure that you have the other pecl  / pear pkgs installed also
$sudo apt-get install php-pear
$sudo apt-get install dh-make-php ## possibly optional but we will include it for now

Third then we run the pecl::svn install
$sudo pecl install svn channel://pecl.php.net/svn-0.5.0

Forth add the line
>extension=svn.so
under the "; Dynamic Extensions ;" section to your php.ini config use phpinfo() for a quick lookup of where it's being loaded from

and restart apache
$sudo /etc/init.d/apache2 restart

chime in if you think i did something wrong or could have done something differently