Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Error on startup

Help
Alex Push
2010-02-11
2013-04-26
1 2 > >> (Page 1 of 2)
  • Alex Push
    Alex Push
    2010-02-11

    I try to start groogle-0.9.2-575 on openSUSE 11.2 and I get the error:

    Parse error: syntax error, unexpected $end in /var/www/groogle/htdocs/template.php on line 152I try to start "groogle" I get the error

    The installed php packages are
    rpm -qa|grep php5
    php5-tokenizer-5.3.0-2.4.3.i586
    php5-shmop-5.3.0-2.4.3.i586
    php5-dba-5.3.0-2.4.3.i586
    php5-pear-5.3.0-2.4.3.noarch
    php5-iconv-5.3.0-2.4.3.i586
    php5-sockets-5.3.0-2.4.3.i586
    php5-fastcgi-5.3.0-2.4.3.i586
    php5-ftp-5.3.0-2.4.3.i586
    php5-xmlrpc-5.3.0-2.4.3.i586
    php5-openssl-5.3.0-2.4.3.i586
    php5-zlib-5.3.0-2.4.3.i586
    php5-phar-5.3.0-2.4.3.i586
    php5-bz2-5.3.0-2.4.3.i586
    php5-hash-5.3.0-2.4.3.i586
    php5-zip-5.3.0-2.4.3.i586
    php5-suhosin-5.3.0-2.4.3.i586
    php5-pgsql-5.3.0-2.4.3.i586
    php5-fileinfo-5.3.0-2.4.3.i586
    php5-bcmath-5.3.0-2.4.3.i586
    php5-ldap-5.3.0-2.4.3.i586
    php5-imap-5.3.0-2.4.3.i586
    php5-xmlwriter-5.3.0-2.4.3.i586
    php5-sqlite-5.3.0-2.4.3.i586
    php5-sysvshm-5.3.0-2.4.3.i586
    php5-pspell-5.3.0-2.4.3.i586
    php5-gmp-5.3.0-2.4.3.i586
    php5-curl-5.3.0-2.4.3.i586
    php5-readline-5.3.0-2.4.3.i586
    php5-sysvsem-5.3.0-2.4.3.i586
    php5-ctype-5.3.0-2.4.3.i586
    php5-xmlreader-5.3.0-2.4.3.i586
    php5-posix-5.3.0-2.4.3.i586
    php5-gettext-5.3.0-2.4.3.i586
    php5-calendar-5.3.0-2.4.3.i586
    php5-odbc-5.3.0-2.4.3.i586
    php5-5.3.0-2.4.3.i586
    php5-wddx-5.3.0-2.4.3.i586
    php5-pdo-5.3.0-2.4.3.i586
    apache2-mod_php5-5.3.0-2.4.3.i586
    php5-snmp-5.3.0-2.4.3.i586
    php5-mbstring-5.3.0-2.4.3.i586
    php5-devel-5.3.0-2.4.3.i586
    php5-mysql-5.3.0-2.4.3.i586
    php5-tidy-5.3.0-2.4.3.i586
    php5-intl-5.3.0-2.4.3.i586
    php5-xsl-5.3.0-2.4.3.i586
    php5-pcntl-5.3.0-2.4.3.i586
    php5-json-5.3.0-2.4.3.i586
    php5-soap-5.3.0-2.4.3.i586
    php5-enchant-5.3.0-2.4.3.i586
    php5-exif-5.3.0-2.4.3.i586
    php5-dom-5.3.0-2.4.3.i586
    php5-sysvmsg-5.3.0-2.4.3.i586
    php5-gd-5.3.0-2.4.3.i586
    php5-mcrypt-5.3.0-2.4.3.i586
    Can anyone help me?

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Do you have short_open_tag set to on in your /etc/php.ini file?

     
  • Alex Push
    Alex Push
    2010-02-11

    Thank. I have changed it setting, but received  it :

    Notice: Use of undefined constant PEAR_LOG_INFO - assumed 'PEAR_LOG_INFO' in /var/www/groogle/htdocs/conf/log.php on line 2

    Eeeeeeeeeeek!
    There was one or more errors whilst checking your installation. Heres a very helpful summary to help you fix it:

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    You need to install the pear log module.  (pear install Log).  Also you need to install the php-pear package if you haven't yet done so.

    Graham

     
  • Alex Push
    Alex Push
    2010-02-11

    I have installed it early.
    rpm -qa|grep pear
    php5-pear-5.3.0-2.4.3.noarch
    php5-pear-log-1.9.11-24.127.noarch

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Have you restarted apache since installing it? Does the output from a phpinfo() test page show /usr/share/pear (or equivilent) in the include path?

     
  • Alex Push
    Alex Push
    2010-02-11

    I have restarted apache.

    cat /etc/php5/apache2/php.ini |grep PEAR
    include_path = ".:/usr/share/php5:/usr/share/php5/PEAR".
    But the problem   has remained.

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Do any of those included directories contain the Log.php file?  if not, find the Log.php file on the command line and add the directory.

     
  • Alex Push
    Alex Push
    2010-02-11

    it is my screen

    Eeeeeeeeeeek!
    There was one or more errors whilst checking your installation. Heres a very helpful summary to help you fix it:

    Status Dependency Diagnosis
    php-gd Ok
    MySQL Ok
    PECL::svn Install the PECL svn extension (and also PECL if you havent already done so). You can install from the command line using the command pecl install svn. Follow the installation instructions from the command line output to install the latest version. Once it is installed add extension=svn.so to /etc/php.d/svn.ini and restart Apache.
    PEAR::Auth Install the PEAR Auth libary (and PEAR if you havent already done so). Groogle uses this for authenticating logons. You can install from the command line using the command pear install Auth. Once it is installed, restart Apache and try again.
    Pear::Text_Diff Install the PEAR Text_Diff extension (and PEAR if you havent already done so). You can install from the command line using the command pear install Text_Diff. Once it is installed, restart Apache and try again.
    Pear::Log Install the PEAR Log extension (and PEAR if you havent already done so). You can install from the command line using the command pear install Log. Try again once it is installed.
    Pear::File_Archive Install the PEAR File_Archive extension (and PEAR if you havent already done so). You can install from the command line using the command pear install File_Archive. Try again once it is installed.
    ==============================================

     
  • Alex Push
    Alex Push
    2010-02-11

    find / -name Log.php
    /usr/share/php5/PEAR/Log.php
    ==========================
    cat /etc/php5/apache2/php.ini |grep PEAR
    include_path = ".:/usr/share/php5:/usr/share/php5/PEAR".

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    find the Log.php file on your filesystem ('updatedb && locate Log.php' or 'rpm -ql php5-pear | grep Log.php') and add the containing folder to your php.ini.  That should get rid of the Pear::Log line.

    Once this is fixed, you should be able to either install the rpm packages for the other modules listed, or use the command line to install them.

    Thanks,

    Graham

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    If you create a test.php file with only this in it…..

    <?php include('Log.php'); ?>
    

    Does it complain when you open it in a browser?

     
  • Alex Push
    Alex Push
    2010-02-11

    It is very strange.
    rpm -qa|grep pear


    php5-pear-5.3.0-2.4.3.noarch
    php5-pear-log-1.9.11-24.127.noarch


    but

    rpm -ql php5-pear | grep Log.php
    blank

     
  • Alex Push
    Alex Push
    2010-02-11

    It is my  test.php

    PHP Version 5.3.0

    System  Linux dev32 2.6.31.12-0.1-desktop #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 i686 
    Build Date  Oct 27 2009 17:15:11 
    Configure Command  '../configure' '-prefix=/usr' '-datadir=/usr/share/php5' '-mandir=/usr/share/man' '-bindir=/usr/bin' '-with-libdir=lib' '-includedir=/usr/include' '-sysconfdir=/etc/php5/apache2' '-with-config-file-path=/etc/php5/apache2' '-with-config-file-scan-dir=/etc/php5/conf.d' '-enable-libxml' '-enable-session' '-with-mm' '-with-pcre-regex=/usr' '-enable-xml' '-enable-simplexml' '-enable-spl' '-enable-filter' '-disable-debug' '-enable-inline-optimization' '-disable-rpath' '-disable-static' '-enable-shared' '-program-suffix=5' '-with-pic' '-with-gnu-ld' '-with-system-tzdata=/usr/share/zoneinfo' '-with-apxs2=/usr/sbin/apxs2' '-disable-all' '-disable-cli' 
    Server API  Apache 2.0 Handler 
    Virtual Directory Support  disabled 
    Configuration File (php.ini) Path  /etc/php5/apache2 
    Loaded Configuration File  /etc/php5/apache2/php.ini 
    Scan this dir for additional .ini files  /etc/php5/conf.d 
    Additional .ini files parsed  /etc/php5/conf.d/bcmath.ini, /etc/php5/conf.d/bz2.ini, /etc/php5/conf.d/calendar.ini, /etc/php5/conf.d/ctype.ini, /etc/php5/conf.d/curl.ini, /etc/php5/conf.d/dba.ini, /etc/php5/conf.d/dom.ini, /etc/php5/conf.d/enchant.ini, /etc/php5/conf.d/exif.ini, /etc/php5/conf.d/fileinfo.ini, /etc/php5/conf.d/ftp.ini, /etc/php5/conf.d/gd.ini, /etc/php5/conf.d/gettext.ini, /etc/php5/conf.d/gmp.ini, /etc/php5/conf.d/hash.ini, /etc/php5/conf.d/iconv.ini, /etc/php5/conf.d/imap.ini, /etc/php5/conf.d/intl.ini, /etc/php5/conf.d/json.ini, /etc/php5/conf.d/ldap.ini, /etc/php5/conf.d/mbstring.ini, /etc/php5/conf.d/mcrypt.ini, /etc/php5/conf.d/mysql.ini, /etc/php5/conf.d/mysqli.ini, /etc/php5/conf.d/odbc.ini, /etc/php5/conf.d/openssl.ini, /etc/php5/conf.d/pcntl.ini, /etc/php5/conf.d/pdo.ini, /etc/php5/conf.d/pdo_mysql.ini, /etc/php5/conf.d/pdo_odbc.ini, /etc/php5/conf.d/pdo_pgsql.ini, /etc/php5/conf.d/pdo_sqlite.ini, /etc/php5/conf.d/pgsql.ini, /etc/php5/conf.d/phar.ini, /etc/php5/conf.d/posix.ini, /etc/php5/conf.d/pspell.ini, /etc/php5/conf.d/readline.ini, /etc/php5/conf.d/shmop.ini, /etc/php5/conf.d/snmp.ini, /etc/php5/conf.d/soap.ini, /etc/php5/conf.d/sockets.ini, /etc/php5/conf.d/sqlite.ini, /etc/php5/conf.d/sqlite3.ini, /etc/php5/conf.d/suhosin.ini, /etc/php5/conf.d/sysvmsg.ini, /etc/php5/conf.d/sysvsem.ini, /etc/php5/conf.d/sysvshm.ini, /etc/php5/conf.d/tidy.ini, /etc/php5/conf.d/tokenizer.ini, /etc/php5/conf.d/wddx.ini, /etc/php5/conf.d/xmlreader.ini, /etc/php5/conf.d/xmlrpc.ini, /etc/php5/conf.d/xmlwriter.ini, /etc/php5/conf.d/xsl.ini, /etc/php5/conf.d/zip.ini, /etc/php5/conf.d/zlib.ini 
    PHP API  20090626 
    PHP Extension  20090626 
    Zend Extension  220090626 
    Zend Extension Build  API220090626,NTS 
    PHP Extension Build  API20090626,NTS 
    Debug Build  no 
    Thread Safety  disabled 
    Zend Memory Manager  enabled 
    Zend Multibyte Support  disabled 
    IPv6 Support  enabled 
    Registered PHP Streams  php, file, glob, data, http, ftp, compress.bzip2, https, ftps, compress.zlib, zip, phar 
    Registered Stream Socket Transports  tcp, udp, unix, udg, ssl, sslv3, sslv2, tls 
    Registered Stream Filters  string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, bzip2.*, convert.iconv.*, zlib.* 
    ====================================================================================
    Thank.

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    That looks like the output from phpinfo();

    What does the output from this give…?

    <?php include('Log.php'); ?>
    

    Tail your /var/log/httpd/*error_log files whilst you access it.

     
  • Alex Push
    Alex Push
    2010-02-11

    The instruction " include('Log.php');"  was add and we have next:

    Warning: include() : Failed opening 'Log.php' for inclusion (include_path='.:')

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Here's the problem…..

    (include_path='.:')

    For whatever reason your apache installation is not using the php.ini include directives you listed above or perhaps the include path is being overwritten?

    Could you paste your php.ini file here?

    Thanks,

    Graham

     
  • Alex Push
    Alex Push
    2010-02-11

    cat /etc/php5/apache2/php.ini

    engine = On
    short_open_tag = on
    asp_tags = Off
    precision = 14
    y2k_compliance = On
    output_buffering = 4096
    zlib.output_compression = Off
    implicit_flush = Off
    unserialize_callback_func =
    serialize_precision = 100
    allow_call_time_pass_reference = Off
    safe_mode = Off
    safe_mode_gid = Off
    safe_mode_include_dir =
    safe_mode_exec_dir =
    safe_mode_allowed_env_vars = PHP_
    safe_mode_protected_env_vars = LD_LIBRARY_PATH
    disable_functions =
    disable_classes =
    expose_php = On
    max_execution_time = 30
    max_input_time = 60
    memory_limit = 128M
    error_reporting = E_ALL & ~E_DEPRECATED
    display_errors = Off
    display_startup_errors = Off
    log_errors = On
    log_errors_max_len = 1024
    ignore_repeated_errors = Off
    ignore_repeated_source = Off
    report_memleaks = On
    track_errors = Off
    html_errors = Off
    variables_order = "GPCS"
    request_order = "GP"
    register_globals = Off
    register_long_arrays = Off
    register_argc_argv = Off
    auto_globals_jit = On
    post_max_size = 8M
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    auto_prepend_file =
    auto_append_file =
    default_mimetype = "text/html"
    include_path = ".:/usr/share/php5:/usr/share/php5/PEAR"
    doc_root =
    user_dir =
    enable_dl = Off
    upload_max_filesize = 2M
    allow_url_fopen = On
    allow_url_include = Off
    default_socket_timeout = 60

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    That looks like a fairly sane config to me.

    Are you running selinux or apparmour?

     
  • Alex Push
    Alex Push
    2010-02-11

    OOOOO… I have disable appapmor and half of  error disappeared… Thank very much!!!!

    I have the following errors:
    PECL::svn
    File upload directory

    Database sanity

    Thank.

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Ok, install the pecl rpm and then run pecl install svn

    It will then give you the exact command you need to run to install PECL::svn.

    The file upload directory needs to be owned +rwx by the apache user.

     
  • Alex Push
    Alex Push
    2010-02-11

    Thank .I have installed PECL::svn.
    But there are following errors:
    LS cache permissions
    File cache permissions
    Diff image cache permissions
    Database sanity


    I created dir cache in /var/www/groogle. Is it right?

     
  • Alex Push
    Alex Push
    2010-02-11

    Sorry.I found the location cache directory and have the problenm only with Database sanity.

     
  • Graham Pitt
    Graham Pitt
    2010-02-11

    Have you run the database installation script in /var/www/groogle/db/?  This script will install and patch the database to the latest required schema version.

     
  • Alex Push
    Alex Push
    2010-02-11

    I try to execute script  /var/www/groogle/db//patchdb.sh

    Applying database patch ./patch1.sql
    Applying database patch ./patch2.sql
    Applying database patch ./patch3.sql
    ERROR 1071 (42000) at line 13: Specified key was too long; max key length is 767 bytes
    Could not apply patch to database.  Something bad happened.  Will not continue.
    ======================================================
    Server version: 5.1.36-log SUSE MySQL RPM

     
1 2 > >> (Page 1 of 2)