#341 Problem with configure

open
nobody
None
5
2005-11-25
2005-11-25
Anonymous
No

I get the following warning from the configure script:
-- Begin Output --
configure: WARNING: cdda_paranoia.h: present but cannot
be compiled
configure: WARNING: cdda_paranoia.h: check for
missing prerequisite headers?
configure: WARNING: cdda_paranoia.h: see the Autoconf
documentation
configure: WARNING: cdda_paranoia.h: section
"Present But Cannot Be Compiled"
configure: WARNING: cdda_paranoia.h: proceeding with
the preprocessor's result
configure: WARNING: cdda_paranoia.h: in the future, the
compiler will take precedence
configure: WARNING: ##
---------------------------------------------------------------
##
configure: WARNING: ## Report this to
http://sf.net/tracker/?group_id=3714&atid=103714 ##
configure: WARNING: ##
---------------------------------------------------------------
##
-- End Output --
I usually don't report warnings, but because the
configure script said I should do so, I figured I'd do
so :-).
System:
Linux kernel 2.4.29
Slackware 10.2
Version: grip-3.3.1(the one from the download page).
I hope this helps.
Hylke

Discussion

  • Chris Craig
    Chris Craig
    2006-08-27

    Logged In: YES
    user_id=287023

    I think the problem is with several years old Makefiles and
    configure scripts. I ran "aclocal", then "automake" and
    "autoconf" before ./configure and other than the following
    warning everything was fine.

    `` config.status: WARNING: po/Makefile.in.in seems to
    ignore the --datarootdir setting ''