Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

gri-mode.el in Windows XP

Help
2006-12-08
2013-04-24
  • juan_alberdi
    juan_alberdi
    2006-12-08

    Hello:

    Could anyone help, please?

    I've just installed the binaries of Gri in my directory c:\Program Files of my Windows XP PC. Copying an example file (example1.gri and .dat) to the folder where gri.exe is, and running gri from that folder on a command line window everything is fine.

    However running gri from another folder the program can not find the example1.dat

    Then I've implemented the gri-mode in my GNU Emacs editor, and I've got the same problem.

    Thank you,
    Juan

     
    • Cody
      Cody
      2006-12-08

      Hi Juan,

      I can help with regard to the first issue (with Windows XP).

      You need to add the directory with the executable to your PATH variable.  Presumably, that directory for you is "c:\Program Files\gri\bin" or something similar.

      If you're not familiar with adding directories to the PATH in Windows, it should be in Control Panel--> System--> Advanced--> Environment Variables--> System Variables.  Look for Path on the left, and its list of semicolon-separated directories on the right.  Add your Gri executable directory to this list.  That should do it.

      Sorry, but I'm unfamiliar with Emacs and can't help you there, but solving the first problem might solve that one, too.

      Best,
      Cody

       
    • juan_alberdi
      juan_alberdi
      2006-12-08

      Dear Cody,

      Thank you very much for your answer.

      I've added the directory of gri to the PATH variable, but actually my problem was with the command 'open' in the file example1.gri. I should have included the full path to the file example1.dat instead of just the command

      open example1.dat

      Now I still have a problem with the gri-mode in Emacs, which I detail in here in case someone might help. I got the following message from Emacs,

      ----------
      fn: c:\Program Files\GnuWin32/etc/popt

      cannot open: c:\Program Files\GnuWin32/etc/popt

      cannot open: C://.popt
      Gri cannot open commandfile `c:/Documents.gri'
      ----------

      gri-mode does not create the .ps file, although if I previously create it myself from the command line, gri-mode sends the above messagge and is able to open ghostview32 and show the example1.ps file.

      Thank you,
      Juan

       
    • juan_alberdi
      juan_alberdi
      2006-12-09

      Hello again,

      I think I've found the solution to my problems running gri from Emacs on my WindowsXP PC.

      It seems that 'gri-mode.el' and/or 'gri.cmd' have been written with Unix style folder/file names in mind. So, when at some time my gri-mode found this file path

      c:\Documents and Settings\ ...

      it stopped at the the first white space, added '.gri' at the end, and complained like,

      Gri cannot open commandfile `c:/Documents.gri'

      So I had to put my gri files in another folder, like

      c:\Gri

      and Emacs gri-mode worked alright.

      Bye,
      Juan