#35 region capture in citrix - blank image

0.8.1
open
nobody
5
2013-01-20
2012-06-28
jon price
No

we have 'hybrid pcs' where the Greenshot (0.8.1 build 1326) is installed locally, as is IE8. Microsoft Word 2010 (integrated into the desktop) is run from a citrix Xenapp server (win 2003 SP2, Presentation Manager 4.5). Our PC clients are Win XP SP3. When doing a region capture of an IE8 screen and pasting into a Word document the image pastes as a blank image. Default paste format is HTML. To get it to paste the actual image Paste Special > bitmap must be selected. On 'normal' Pc clients (with all apps locally installed) this does not happen and the Paste works normally. Is this a known 'feature' is there a fix? Or any work around which would mean being able to paste the image without using Paste Special?

Discussion

  • Robin Krom
    Robin Krom
    2012-07-04

    Hi Jon,

    To understand the problem, here some background information:
    The windows clipboard is a temporary storage which accepts only 1 "item" at a time but in multiple formats. The application that stores information on it, decides which formats it supplies! BUT the application which is used to paste into it decides which format is taken from the clipboard. Word seems to prefer HTML, which normally isn't problem... In your case the user is pasting into an application which just passes the HTML information along from the client PC to the Citrix server. In the case of Greenshot, the HTML has a LOCAL path (to the temp directory) to an image in it, the application on the server receives the HTML and can't find the image (as it's not on the server) and the result is a blank image. This explains why pasting using a different format works.

    I would advice you to have a look at Greenshot 1.0, although we are still finishing it it's already most likely more stable than the 0.8.1 you are using. But more important, with it you can specify in the expert tab of the setting which format is stored on the clipboard! I would disable HTML, and this should fix this special case you have.

    The clipboard is a nasty thing, therefor we invested a lot of effort into building solutions which don't use this. With 1.0 we have export to most office applications, like Outlook, Word etc. But this won't work in your case, as Greenshot runs locally and Work remotely... You might want to try to run Greenshot via Citrix, I have heard this should work! But I can't garantee if the exports etc work, we don't use Citrix...

    The settings for 1.0 are stored inside an ini file which you can even pre-define in your rollout prcoess. The expert tab can be disabled in the settings. I still need to write some blog entries about the ini files, but some details can be read here: https://sourceforge.net/projects/greenshot/forums/forum/676082/topic/5355465

    Best wishes,
    Robin

     
  • Hello presently there. I found your site using bing. This generally is a very well crafted article. I shall be bound for you to bookmark this and application discover more of ones useful data. Was looking for post. Ill definitely return.
    [url=http://www.ceofusion.org/node/85232]The very best[/url]
    <a href="http://www.ceofusion.org/node/85232" title="The very best">The very best</a>

     
  • YNGk5r <a href="http://idwoxuidieba.com/">idwoxuidieba</a>, [url=http://phuvlwlxyaty.com/]phuvlwlxyaty[/url], [link=http://uapjfdygdxpr.com/]uapjfdygdxpr[/link], http://nzbhhiizbcjt.com/