An instance of Greenshot is already running

  • Shaul

    Thank you for this excellent and useful application. I use it almost daily.  Here is a little problem:
    Whenever I start my computer I get a pop-up saying: An instance of Greenshot is already running followed by two lines:
    1: C:\Program Files\Greenshot\Greenshot.exe
    2: C:\Program Files\Greenshot\Greenshot.exe

    Please tel me how to rid of this. Thank you!

  • Mike

    Check your \Run key in your regedit.  Make sure Greenshot isn't in there twice:


    You might check your Start/All Programs/Startup to make sure Greenshot didn't get in there as well.

  • Robin Krom
    Robin Krom

    You might have Greenshot in your startup, and/or multiple times in the registry. This might have happened due to us switching from 32 to 64 bit and having entries in both areas of the registry.

    But what you can do is install our RC5, which we uploaded yesterday, and go into the setting, uncheck the "start at windows startup" press ok. Than go back again, and you can select it again, press ok. All doubles "should" be removed…

    Best wishes,

  • Jj4ssvYg

    I had the exact error in Windows 7 x64 Pro. I had to install from zip and run it in a different folder than the automatic setup method. Then I proceeded to uninstall the automatic setup installation. Avoid automatic setup install, stick with the zip.

  • Robin Krom
    Robin Krom

    No, please don't stick to the zip!! With 1.0.6 most installation issues should be fixed, but if someone still has a very old version the unstaller of this version might forget to remove the entry in the start-menu. You can just delete this manually and you are good. (Start->All Programs->Auto Start)

    There are some benefits of the installer, first it checks pre-requisites and it makes it possible to start Greenshot when starting your PC. Additionally we will register file types with 1.1 (we have our own) and it will optimize the performance of Greenshot. Besides the .zip can cause a lot of problems when people don't know what they are doing… e.g. copy Plugins from a different version.

  • Byron

    I have experienced the same issue with Greenshot and found a solution to the error message:

    "An instance of Greenshot is already running.
    1: C:\Program Files\Greenshot\Greenshot.exe"

    Right-Click on the Greenshot.exe (found in the Start Menu/All Programs).
    Click on 'Properties' and Click on the 'Compatibility' tab.
    Under 'Compatibility Mode' select 'Run this program in compativility mode for:'.
    Click on the drop-down menu and select 'Windows Vista (Service Pack 2).
    Click 'OK'.

    I hope this helps!

    Last edit: Byron 2013-01-22
    • It worked! Thanks!

  • I tried all the above but nothing worked. In the end I deleted Greenshot.exe.config from C:\Program Files\Greenshot. Now I can run the 64 bit executable without issue.

  • Robin Krom
    Robin Krom

    Hi Joseph, I don't understand why deleting that file helped... Can you tell us how you came to that solution?

    Also I wonder if this problem has anything to do with the .NET version(s) that are available, can someone who has this problem tell me what is installed on his system?

    Best wishes,

  • This issue came up again in Win 7 x64, so my previous post isn't the answer. No running processes, no startup item for Greenshot in either the startup folder or msconfig, and the Greenshot.exe.config is gone as my previous post noted. I couldn't find Greenshot in the 'Add and Remove Programs' dialogue, which was strange. Ran unins000 manually from the install folder. Going to try the latest version.

  • Ok, so the problem came up again after uninstalling, re-installing with the latest. I edited the Greenshot.exe.config rather blindly, and updated the following:

    • <?xml version="1.0" encoding="utf-8" ?>


    • <?xml version="2.0" encoding="utf-8" ?>

    Strangely enough, I can repeat this issue by editing back to 1.0, problem goes away when I edit it to 2.0 again.

    Last edit: Joseph Ridenhour 2013-03-26
  • I am simply amazed.
    The program ran for months until a recent Windows update (Win 7, 64 bit).
    Since then I had the same issue: no autostartup, no registry entry, just rebooted computer but I'd still get the error message.

    The above solution (change the xml version to 2.0) actually works!
    I don't know if it's because of some MS runtime acting up or anything, but now I can use Greenshot again!

  • Robin Krom
    Robin Krom

    There is no such thing as a XML version 2.0, so I guess when you chance this the Greenshot.exe.config just isn't read as the file is not valid.

    The question is, what version of Greenshot are you using?

  • Phil

    I have the same error. To track down the cause I disabled all startup programs except Greenshot using MSCONFIG. I enabled one at a time restarting windows each time. In my case the Intel USB 3.0 monitor was conflicting with Greenshot. Reading several discussions about the Intel USB 3.0 monitor this is just one in a long list of problems it causes.

    Hope this helps.

    Last edit: Phil 2015-07-11