Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1397 send to excel

1.0.6
closed
nobody
Unknown (100)
5
2014-03-07
2012-11-27
Anonymous
No

this message came up

Software version: 1.0.6.2228 (64 bit)
.NET runtime version: 4.0.30319.586
Time: 2012-11-27 09:34:36 -06:00
OS: Windows 7 Ultimate Service Pack 1 (x64) 6.1 build 7601 revision 10000
GDI object count: 102
User object count: 90
Exception: System.Runtime.InteropServices.COMException
Message: Call was rejected by callee. (Exception from HRESULT: 0x80010001 (RPC_E_CALL_REJECTED))

ErrorCode: 0x80010001

Stack:

Server stack trace:
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at Greenshot.Interop.COMWrapper.Invoke(IMessage myMessage)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Greenshot.Interop.Office.IExcelApplication.set_Visible(Boolean value)
at Greenshot.Interop.Office.ExcelExporter.InsertIntoNewWorkbook(String tmpFile)
at GreenshotOfficePlugin.ExcelDestination.ExportCapture(Boolean manuallyInitiated, ISurface surface, ICaptureDetails captureDetails)
at Greenshot.ImageEditorForm.DestinationToolStripMenuItemClick(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Configuration dump:
[Core]
Language=en-US
RegionHotkey=PrintScreen
WindowHotkey=Alt + PrintScreen
FullscreenHotkey=Ctrl + PrintScreen
LastregionHotkey=Shift + PrintScreen
IEHotkey=Ctrl + Shift + PrintScreen
IsFirstLaunch=False
Destinations=Editor
ClipboardFormats=DIB,PNG
CaptureMousepointer=False
CaptureWindowsInteractive=False
CaptureDelay=100
ScreenCaptureMode=Auto
ScreenToCapture=1
WindowCaptureMode=Auto
WindowCaptureAllChildLocations=False
DWMBackgroundColor=Transparent
PlayCameraSound=False
ShowTrayNotification=True
OutputFilePath=C:\Users\kevin.ENERQUEST\Documents\JUNK\Captured Screen Images
OutputFileAllowOverwrite=True
OutputFileFilenamePattern=${capturetime:d"yyyy-MM-dd HH_mm_ss"}-${title}
OutputFileFormat=tiff
OutputFileReduceColors=False
OutputFileAutoReduceColors=True
OutputFileCopyPathToClipboard=True
OutputFileAsFullpath=C:\Users\kevin.ENERQUEST\Documents\JUNK\2012-11-19 10_35_14-Image detail for -Carolina Panthers Team Wall...jpg
OutputFileJpegQuality=100
OutputFilePromptQuality=False
OutputFileIncrementingNumber=1
OutputPrintPromptOptions=False
OutputPrintAllowRotate=True
OutputPrintAllowEnlarge=True
OutputPrintAllowShrink=True
OutputPrintCenter=True
OutputPrintInverted=False
OutputPrintGrayscale=False
OutputPrintFooter=False
OutputPrintFooterPattern=${capturetime:d"D"} ${capturetime:d"T"} - ${title}
NotificationSound=default
UseProxy=True
IECapture=True
IEFieldCapture=False
WindowClassesToCheckForIE=AfxFrameOrView70,IMWindowClass
AutoCropDifference=10
IncludePlugins=
ExcludePlugins=
ExcludeDestinations=OneNote
UpdateCheckInterval=1
LastUpdateCheck=11/26/2012 11:06:28
DisableSettings=False
DisableQuickSettings=False
DisableTrayicon=False
HideExpertSettings=False
ThumnailPreview=True
NoGDICaptureForProduct=intellij,idea
NoDWMCaptureForProduct=citrix,ica,client
OptimizeForRDP=False
MinimizeWorkingSetSize=False
CheckForUnstable=False
ActiveTitleFixes=Firefox,IE,Chrome
TitleFixMatcher.Firefox= - Mozilla Firefox.*
TitleFixMatcher.IE= - (Microsoft|Windows) Internet Explorer.*
TitleFixMatcher.Chrome= - Google Chrome.*
TitleFixReplacer.Firefox=
TitleFixReplacer.IE=
TitleFixReplacer.Chrome=
EnableSpecialDIBClipboardReader=True

Discussion

  • Robin Krom
    Robin Krom
    2012-11-27

    The problem is most likely that you have some kind of dialog open, this makes Excel reject the export.

    With Greenshot versions build after our 1.0.6 this will be fixed, but currently there are no publicly available versions yet.

    Best wishes,
    Robin

     
  • Robin Krom
    Robin Krom
    2012-11-28

    • status: open --> closed-fixed
     
  • Robin Krom
    Robin Krom
    2012-11-28

    Will be fixed with Greenshot 1.1

     
  • Jens Klingen
    Jens Klingen
    2013-04-04

    • Status: closed-fixed --> closed