#1388 Crash when performing window captures at short intervals

0.8.0
closed
nobody
Capture (303)
5
2013-04-04
2012-11-14
Anonymous
No

Software version: 0.8.0.627
.NET runtime version: v2.0.50727
Time: 2012-11-14 11:05:22 +01:00
OS: Build 7601 Service Pack 1
GDI object count: 48
User object count: 33
Exception: System.NullReferenceException
Message: Object reference not set to an instance of an object.

Stack:
at Greenshot.Drawing.Surface..ctor(Image image)
at Greenshot.Drawing.Surface..ctor(ICapture capture)
at Greenshot.Forms.CaptureForm.HandleCapture()
at Greenshot.Forms.CaptureForm.finishCapture()
at Greenshot.Forms.CaptureForm.MakeCapture(CaptureMode mode, Boolean captureMouseCursor, ICapture newCapture)
at Greenshot.Forms.CaptureForm.MakeCapture(CaptureMode mode, Boolean captureMouseCursor)
at Greenshot.MainForm.CaptureWindow()
at Greenshot.Helpers.HotkeyHelper.HandleMessages(Message& m)
at Greenshot.MainForm.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Discussion

  • Jens Klingen
    Jens Klingen
    2012-11-14

    • status: open --> pending-works-for-me
     
  • Jens Klingen
    Jens Klingen
    2012-11-14

    Could you please try our latest release (1.0) and let us know whether you still have problems?
    A lot of capture related things have changed since version 0.8 and as I cannot reproduce this, I think this issue might be resolved by now.

    Get Greenshot at http://getgreenshot.org/ and please drop another comment if the problem persists.

    Thanks and best regards,
    Jens

     
  • Robin Krom
    Robin Krom
    2012-11-14

    • status: pending-works-for-me --> closed-fixed
     
  • Robin Krom
    Robin Krom
    2012-11-14

    Hello,

    This problem is fixed with Greenshot 1.0, get it here: http://getgreenshot.org/downloads/

    If the problem somehow still exists in 1.0, or you find any others, please let us know here: http://getgreenshot.org/tickets/

    Best wishes,
    The Greenshot team

     
  • Jens Klingen
    Jens Klingen
    2013-04-04

    • Status: closed-fixed --> closed