#16 Seems to be missing dependency.

v2.4.0
closed
nobody
5
2008-02-27
2007-12-06
hmsdefender
No

NOTE: Also posted on Green forum

I installed and verified installation of Green as specified in documentation. I have an Eclipse 3.3 environment with GEF 3.3 and Java 1.6 on a Suse Enterprise Linux 10.3 platform. When I try to set Green preferences I get the following error…

“Unable to create the selected preference page. (Time of error: December 4, 2007 3:53:53 PM EST)

Reason:
Edu/buffalo/cse/green/preferences/GreePreferencePageClassBox (Unsupported major.minor version 49.0)

I tried building class diagrams by right clicking on a package and selecting GreenUML->Add to New Class Diagram. I got the following error…

“Chosen operation is not currently available.”

Are there other dependencies to Green 3.0 other than Eclipse 3.3 and GEF 3.3? If not, any idea what the problem may be?

Discussion

  • Gene Wang
    Gene Wang
    2008-02-12

    • status: open --> pending
     
  • Gene Wang
    Gene Wang
    2008-02-12

    Logged In: YES
    user_id=1520789
    Originator: NO

    It appears that Eclipse is not loading Green's class using Java 1.6 but rather is attempting to load them using a pre-Java 1.5 class loader. Ensure that JDK 1.6 is your default version of Java. Let us know if this does not resolve the issue.

     
    • status: pending --> closed
     
  • Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).